Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#346 Empty message in HTML mode

open
Jamie Cameron
Read Mail (122)
5
2008-04-21
2008-04-21
Anonymous
No

Cannot display some types of HTML based messages. Most instances I've noticed the problem with .NET Mime encapsulated HTML messages. The message appears/readable if preferences are set to view in Text mode, but some data is lost. If the link "View in HTML" is clicked on, the message fails to display at all.

There may be other instances where HTML based messages are not displayed correctly. Most cases switching to text mode is the work-around.

Oddly, the same message can be viewed using squirrelmail and is rendered in HTML mode properly. (sorry) So the problem seems confined to the HTML rendering engine usermin uses.

Problem appears in 1.340 and previous versions at least as early as 1.300 when I first started noticing the problem. HTML viewing problem is present whether using IE6, Opera 9.27, or Mozilla 2.0.14 browsers.

Unfortunately, I cannot submit a email example as the ones it failed on contained confidential information from travel reservation sites, or credit card purchases. (sorry) If I come across other instances that are not confidential I will gladly forward them on as test examples.

Discussion

  • Jamie Cameron
    Jamie Cameron
    2008-04-21

    Logged In: YES
    user_id=129364
    Originator: NO

    Thanks for the bug report .. although I can't really debug this without seeing an HTML message that exhibits the problem.

    If you have one, forward it to me (with all headers) at jcameron@webmin.com , and I will debug.

     
  • Jamie Cameron
    Jamie Cameron
    2008-05-06

    Logged In: YES
    user_id=129364
    Originator: NO

    Any further news on this?