#262 mail gets lost

1.180
closed
Jamie Cameron
Read Mail (122)
5
2006-04-11
2006-02-23
Arco van Geest
No

When mutations are done to a mailbox containing more
then about 500 emails and the server is busy the
mailbox is empty afterwards.

I can't seem to reproduce it but users tell me it
happened since the seperate search-box.

Could it be a locking problem on the unix mailbox?

Arco

Discussion

  • Jamie Cameron
    Jamie Cameron
    2006-02-24

    Logged In: YES
    user_id=129364

    What kind of operations in Usermin are triggering this
    problem? Is it the deletion of mail, or editing messages?
    Also, are you using mbox or Maildir format for your mail store?

     
  • Arco van Geest
    Arco van Geest
    2006-02-26

    Logged In: YES
    user_id=157744

    It occurs when removing (from the inbox).
    the inbox is /var/spool/mail and the Maildir format is:
    sendmail style single mbox.

     
  • Jamie Cameron
    Jamie Cameron
    2006-02-27

    Logged In: YES
    user_id=129364

    Do your users have any disk quotas in effect, or is the
    system perhaps low on disk space? When Usermin deletes mail
    from a mbox format mail file, it needs to create a temp file
    of almost the same size as the original, which can use up a
    lot of space.
    For this reason, I actually prefer the ~/Maildir format for
    large mailboxes .. although to use this, you need to
    re-configure your mail server or Procmail.

     
  • Arco van Geest
    Arco van Geest
    2006-03-05

    Logged In: YES
    user_id=157744

    I converted the system to Maildir now.
    Now the time will tell.

    Thnx

     
  • Jamie Cameron
    Jamie Cameron
    2006-04-11

    • status: open --> closed
     
  • Jamie Cameron
    Jamie Cameron
    2006-04-11

    Logged In: YES
    user_id=129364

    I am guessing this is resolved then..

     
  • Arco van Geest
    Arco van Geest
    2006-04-12

    Logged In: YES
    user_id=157744

    I had no problems losing mail anymore.
    A lot of actions are a lot faster now.

    (this doesn't resolve the "reply answers the wrong mail when
    new mail was received" problem.

    This bug can be closed.

    Arco