Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#243 read mail display list out of sync with true mail order

open
Jamie Cameron
Read Mail (122)
5
2005-11-03
2005-11-03
Anonymous
No

I just updated Usermin to version 1.170. After doing so I
have noticed that when I click on a particular email
message for display, the message that is dusplayed is
the subsequent email message, not the one I selected.
The counter that associates display information and true
email appears to be off by one. A previously reported
bug solution here suggested one delete the com/dir/pag
extension files, which I did. The problem persists.

Discussion

  • Jamie Cameron
    Jamie Cameron
    2005-11-04

    Logged In: YES
    user_id=129364

    Does this happen all the time, or only when a message has
    arrived since the list was displayed? If it is the latter,
    this is a known bug that I am still working on ..
    One work-around may be to click on the Reset Sort link, as I
    think that sorting is the underlying cause of the problem.

     
  • Logged In: NO

    I believe it is only when a message has arrived since the
    list was displayed. Thanks.

     
  • Archie Warnock
    Archie Warnock
    2005-12-17

    Logged In: YES
    user_id=107416

    I notice this with replies, too. This seems to reproduce
    the situation reliably:

    1. Select and read a message.
    2. Wait for a new message to arrive without returning to
    the menu.
    3. Hit the Reply button.

    The result will bring up the wrong message for reply. It
    looks as if the message counters are being updated in
    background, causing an "off-by-one" problem with the
    currently-selected message.

     
  • Archie Warnock
    Archie Warnock
    2005-12-17

    Logged In: YES
    user_id=107416

    > Does this happen all the time, or only when a message has
    > arrived since the list was displayed? If it is the latter,
    > this is a known bug that I am still working on ..

    In my experience it's the latter, but...

    > One work-around may be to click on the Reset Sort link, as
    > I think that sorting is the underlying cause of the
    > problem.

    Except that there is no Reset Sort link when I'm viewing a
    message (which I have to be doing to reply), right? That's
    awkward enough, but if the same behavior happens when trying
    to delete a message, that's a critical bug because you'd
    delete the wrong message.

    From the user perspective, it doesn't look like sorting,
    although that could be what's going on underneath. When I'm
    reading a message, the URL shows the idx value and (I'm
    guessing), when a new message arrives, the idx values shift
    but, of course, not for the particular message being
    displayed. When calling up the message for reply (or
    delete) by idx value, you get the right idx but it's
    pointing to the wrong message.

    Am I close? <grin>

    Glad you aleady know about it, and hope it's fixed soon.
    Thanks!