Hi Jamie,

I tested with port 143 and this is what i get:

telnet mydomain 143                                                                                                      ~
Trying xx.xx.xx.xx...
Connected to mydomain.
Escape character is '^]'.
* OK Dovecot ready.
user test.mydomain
user BAD Error in IMAP command received by server.

And in my /var/log/mail.log:
Oct 29 02:32:28 debian dovecot: imap-login: Disconnected: rip=127.0.0.1, lip=127.0.0.1, secured
Oct 29 02:32:30 debian dovecot: pop3-login: Disconnected: rip=127.0.0.1, lip=127.0.0.1, secured
Oct 29 02:32:31 debian postfix/smtpd[2773]: connect from debian.local[127.0.0.1]
Oct 29 02:32:31 debian postfix/smtpd[2773]: lost connection after CONNECT from debian.local[127.0.0.1]
Oct 29 02:32:31 debian postfix/smtpd[2773]: disconnect from debian.local[127.0.0.1]

Is there something else I can tail to get more info??


2011/10/28 Jamie Cameron <jcameron@webmin.com>

You can't telnet to port 993 , as it is for IMAP over SSL .. and telnet only makes an un-encrypted connection.

Try telnet to port 143 (un-encrypted IMAP) instead, or use the openssl command to connect to port 993 like :

openssl s_client -host mydomain -port 993 

On 28/Oct/2011 16:53 Matías Montenegro <matiasmmontenegro@gmail.com> wrote ..

Hello everybody,

I'm trying to configure the mailing service (Postfix + Dovecot). It sends emails perfectly from the server since virtualmin sends me an email every time a new virtualhost is created, but I can't get to configure my client (I'm trying with thunderbird) and I tried every possible combination (IMAP, POP3, SSL/TLS).

I created a user in the "Create a mail and ftp user" in virtualmin. which is called test.mydomain

I access telnet this way:
telnet mydomain 993
Trying xx.xx.xx.xx...
Connected to mydomain.com.
Escape character is '^]'.
user test.mydomain
Connection closed by foreign host.

In the meanwhile i'm tailing /var/log/mail.log
Oct 28 23:55:19 debian dovecot: imap-login: SSL_accept() failed: error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol [yy.yy.yy.yy]
Oct 28 23:55:19 debian dovecot: imap-login: Disconnected: rip=yy.yy.yy.yy, lip=xx.xx.xx.xx, TLS handshake
Oct 28 23:55:28 debian dovecot: imap-login: Disconnected: rip=127.0.0.1, lip=127.0.0.1, secured
Oct 28 23:55:30 debian dovecot: pop3-login: Disconnected: rip=127.0.0.1, lip=127.0.0.1, secured
Oct 28 23:55:31 debian postfix/smtpd[32622]: connect from debian.local[127.0.0.1]
Oct 28 23:55:31 debian postfix/smtpd[32622]: lost connection after CONNECT from debian.local[127.0.0.1]
Oct 28 23:55:31 debian postfix/smtpd[32622]: disconnect from debian.local[127.0.0.1]

Can anybody give me a clue, I'm completely lost here.

Thank you






--
Matias



------------------------------------------------------------------------------
Get your Android app more play: Bring it to the BlackBerry PlayBook
in minutes. BlackBerry App World&#153; now supports Android&#153; Apps
for the BlackBerry&reg; PlayBook&#153;. Discover just how easy and simple
it is! http://p.sf.net/sfu/android-dev2dev

-
Forwarded by the Webmin mailing list at webadmin-list@lists.sourceforge.net
To remove yourself from this list, go to
http://lists.sourceforge.net/lists/listinfo/webadmin-list




--
Matias