Hi Jamie,

 

Yes, when I don’t fill in the surname field, I get Failed to add user to LDAP database : no structuralObjectClass operational attribute.

 

And yes, I added it to the correct field: LDAP properties for all new users.

 

Rob Tielen

 

Van: webadmin-list-bounces@lists.sourceforge.net [mailto:webadmin-list-bounces@lists.sourceforge.net] Namens Jamie Cameron
Verzonden: vrijdag 29 februari 2008 0:04
Aan: Webmin users list
Onderwerp: Re: [webmin-l] Virtualmin and LDAP

 

Hi Rob,

Do you get an error if you don't fill in the surname field when adding a new user in the LDAP Users and Groups module?

Also, are you sure you added sn: unknown to LDAP properties for all new users and not modified users ?

 - Jamie

On 28/Feb/2008 14:22 Rob Tielen wrote ..

Hello Jamie,

First of all thanks for all the effort you put in helping all of us.

Maybe I can spend some hours to help you (e.g. creating howto’s or extra help pages in Dutch or English).

About the problem: unfortunately it doesn’t help.

I have added to LDAP properties for all new users field sn: unknown.

This didn’t help, so I went back to LDAP users and groups and tried to add a user without a surname (sn).

My expectation was that this user would be added with an sn of unknown (like if I filled in the lastname field), but it didn’t.

Then I filled in a surname (xyz) and the entry was added to the ldap directory with a surname of: unknown xyz.

It appears to me that the existence of surname is checked and if it is not available, the entry is rejected.

When it is available, then the LDAP properties for all new users is added to the sn property.

 

Thanks again for your answer.

 

Rob Tielen

 

Van: webadmin-list-bounces@lists.sourceforge.net [mailto:webadmin-list-bounces@lists.sourceforge.net] Namens Jamie Cameron
Verzonden: donderdag 28 februari 2008 21:59
Aan: Webmin users list
Onderwerp: Re: [webmin-l] Virtualmin and LDAP

 

On 28/Feb/2008 10:17 Rob Tielen wrote ..

Hello,
 

I have got virtualmin running and try to add users to an LDAP directory.

Everything works fine with LDAP users and groups when I switch on: Show fields for given name and surname and give a username in Last Name.

Unfortunately when I use virtualmin to add a new domain (and user), it fails: with failed to create administration user!

Virtualmin version is 3.522, webmin version 1.400.

Do you have any hints for me how to solve this problem?

 

This suggests that your LDAP schema requires that the 'sn' attribute by set.
You can have it do this automatically as follows :

  1. Go to the LDAP Users and Groups module, and click on Module Config.
  2. In the LDAP properties for all new users field, enter something like :
    sn: Unknown
  3. Click Save, then re-try creating a domain in Virtualmin.

 - Jamie