Virtualmin error

Virtualmin
Minase
2008-07-03
2013-05-21
  • Minase
    Minase
    2008-07-03

    when i try to access Features and Plugins and virtualmin i get this
    "require virtual-server/virtual-server-lib.pl failed :

    Undefined subroutine &virtual_server::init_config called at /var/webmin/webmin-1.420/virtual-server/virtual-server-lib.pl line 5.
    "
    what can be wrong? i have setuped just 2 users there and it seem that problem poped up
    my first lines of virtual-server-lib.pl
    "# virtual-server-lib.pl
    # Common functions for Virtualmin

    do '../web-lib.pl';
    &init_config();
    do '../ui-lib.pl';
    use Time::Local;"

    without quotes

    thanks

     
    • require virtual-server/virtual-server-lib.pl failed :

      Undefined subroutine &virtual_server::init_config called at /usr/libexec/webmin/virtual-server/virtual-server-lib.pl line 5.

      I'm getting the same error in just about every function of Virtualmin GPL.

      I've tried completely removing it from the system.

      It was initially installed via RPM. so I rpm -e'd it.

      Then I installed it via module on webmin.

      I'm currently running version 3.59 GPL.

      I've tried downgrading version by version until 3.54 GPL.

      And then upgrading it back again to the latest 3.59 GPL.

      No luck.

      I see that you got no help nor replies to your message as well...

      - regards

      Virtualmin has been rendered completely useless for some reason at some point, I feel it was when I updated it to the latest -1 version. Ever since it is a no go, always getting the error message above.

       
    •