IP access control using TCP-wrappers is not available, as the Authen::Libwrap Perl module is not installed

  • Seventhfire
    Seventhfire
    2013-12-28

    Running new install of ubuntu 12.04.03 with webmin 1.660 trying to setup IP Access Control and webmin shows message below on config page.
    "IP access control using TCP-wrappers is not available, as the Authen::Libwrap Perl module is not installed. Click here to have Webmin automatically install the missing Perl module."
    When I click the install link given and I'm taking to the Install Module page, I hit "Continue With Install"
    I receive the errors below in the Compiling module
    "Executing /usr/bin/perl Makefile.PL && make ..

    running Build.PL

    do you want to link against /usr/lib/libwrap.so? [y ]y
    do you want to use /usr/include/tcpd.h as your header? [y ]y
    Warning: ExtUtils::CBuilder not installed or no compiler detected
    Proceeding with configuration, but compilation may fail during Build

    Checking prerequisites...
    build_requires:
    ! Test::Exception is not installed

    ERRORS/WARNINGS FOUND IN PREREQUISITES. You may wish to install the versions
    of the modules indicated above before proceeding with this installation

    Run 'Build installdeps' to install missing prerequisites.

    Created MYMETA.yml and MYMETA.json
    Creating new 'Build' script for 'Authen-Libwrap' version '0.22'
    sh: 1: make: not found"