#79 Problems with apache on slackware 8.0.0

0.86
closed
Jamie Cameron
5
2001-06-21
2001-06-19
Anonymous
No

I'm using slackware 8.0.0 with apache 1.3.20 and perl
5.6.1.
When using the apache module and I create a new
virtual server, I get three virtual servers with the
same specs back. The same goes for creating directory
options.
It also slows down the machine and consumes large
amounts of memory.

Discussion

  • Jamie Cameron
    Jamie Cameron
    2001-06-19

    Logged In: YES
    user_id=129364

    If you look at the actual apache config file
    (probably /var/lib/httpd/conf/httpd.conf), does the
    new <VirtualHost> directive actually appear in there
    three times?

     
  • Logged In: NO

    I use a seperate file for the virtual hosts, but it there's
    only 1 <VirtualHost> definition. So it seems like the
    apache module goes wrong somewhere when it's creating the
    server list and the directory list. When I remove one, it
    also removes every simular entry webmin is showing in the
    list.

     
  • Jamie Cameron
    Jamie Cameron
    2001-06-19

    Logged In: YES
    user_id=129364

    It looks like webmin is reading the same config file
    multiple times. Check the Module Config and make sure
    that in the 3 'Path to XXX.conf' fields you don't have the
    same file 3 times - on have a file that is included into
    another file.

     
  • Logged In: YES
    user_id=248915

    The problem was on a misinterpretation of the
    sentence 'Path to ...'. I did only fill in the path names,
    not the file names. After filling in the path and the
    filename, it all worked well.
    On the new slackware/apache release, the apache
    configuration files are placed in /etc/apache.
    Anyway, tnx for the quick response. :)

     
  • Jamie Cameron
    Jamie Cameron
    2001-06-21

    • status: open --> closed