#45 Perl modules not showing any description

0.85
closed
Jamie Cameron
5
2001-05-30
2001-05-25
Anonymous
No

On Redhat 6.2 i installed my own perl 5.6.1 with a -d
option, prefix to /usr in stead of /usr/local since
redhat did the same, and a lot of modules, and
everything runs fine.

Both rpm and tar.gz package of webmin are tried, but
give the same (not destructive) error.

/etc/webmin/start # works fine, no errors

browse to https://127.0.0.1:10000/cpan/
# ok, works, but no Descriptions of the modules are
given, also not when clicking on one of them.

The modules are shown as module::module|module::module
e.g. : Net::SFTP::NetSFTP
Version and installation date work fine.

In the console you see (per module) the following
error:
sh: module::module: command not found.
e.g. : sh : Net::SFTP: command not found.

The modules are working properly though.

Any idea?

Discussion

  • Jamie Cameron
    Jamie Cameron
    2001-05-28

    Logged In: YES
    user_id=129364

    Definately a webmin bug. Could you email your
    /usr/lib/perl5/5.006/i386-linux-thread/perllocal.pod file
    (or wherever
    it is located) to me at jcameron@webmin.com ? Sounds like
    the
    format is different to what webmin expects ..

     
  • Jamie Cameron
    Jamie Cameron
    2001-05-30

    • status: open --> closed
     
  • Jamie Cameron
    Jamie Cameron
    2001-05-30

    Logged In: YES
    user_id=129364

    I've figured this one out, and the next release of webmin
    (due very soon) will include a fix for it.