#4280 False alarm and display error in Apache Module

Other
closed-fixed
nobody
None
5
2013-08-19
2013-08-15
Epyx
No

I am using Webmin 1.640 and the new Apache Module fix.
Installed Apache Version is 2.2.22

If i open the Apache Server Module in Webmin it says always Start Apache in the top right corner, but apache is running without any problems.

If i click it, i get the "empty" error message:
:
Starting web server: apache2.

Discussion

  • Jamie Cameron
    Jamie Cameron
    2013-08-15

    Which Linux distribution and version are you running WEbmin on there?

     
  • Chris
    Chris
    2013-08-16

    Same issue here, driving me NUTS!!! Ubuntu 12.04

     
  • Chris
    Chris
    2013-08-16

    Specifically Webmin 1.640 and Apache2 2.2.22
    Error:
    Failed to start apache :
    :
    * Starting web server apache2
    ...done.

    FWIW, Apache does WORK, but that doesn't matter. What good is it if I can't modify it?

    Also, in Webmin systemlogs for Apache it no displays this:
    File /etc/apache2/${APACHE_LOG_DIR}/error.log Yes Apache error log

     
  • Chris
    Chris
    2013-08-16

    tried downgade to webmin 1.630 like another thread said...that didnt work either.

     
  • Jamie Cameron
    Jamie Cameron
    2013-08-16

    Ok, a fix for this is now available from http://www.webmin.com/updates.html . You should also get prompted to install this system on the System Information page that appears after logging into Webmin.

     
  • Epyx
    Epyx
    2013-08-19

    Thanks the fix is working very good!
    PS: i am using Debian 7.0 with Webmin 1.640

     
  • Jamie Cameron
    Jamie Cameron
    2013-08-19

    • status: open --> closed-fixed
     
  • Jamie Cameron
    Jamie Cameron
    2013-08-19

    FYI, Webmin 1.650 has just been released which also includes this fix.