Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#421 RPM won't install as rpm or deb

0.950
closed
Jamie Cameron
5
2002-05-31
2002-04-12
Anonymous
No

zork:/etc/webmin# rpm -U webmin-0.950-1.noarch.rpm
error: cannot open Packages index using db3 - No such
file or directory (2)
error: cannot open Packages database in /var/lib/rpm

I'm assuming that whatever is wrong in here is also
corrupting the alien'd deb file.

Discussion

  • Jamie Cameron
    Jamie Cameron
    2002-04-12

    Logged In: YES
    user_id=129364

    I don't think there is anything wrong with the webmin RPM.
    Are you running a debian system? If so, a better option
    would be to install the webmin package from APT ..

     
  • Jamie Cameron
    Jamie Cameron
    2002-04-12

    • status: open --> closed
     
  • Logged In: NO

    What package though? apt-get doesn't find any webmin
    packages....

    And now I'm trying it with the tar.gz version and running
    setup.sh, it fails to run perl for its check and perl is
    there...

    Very strange....

     
  • Jamie Cameron
    Jamie Cameron
    2002-04-12

    • status: closed --> open
     
  • Jamie Cameron
    Jamie Cameron
    2002-04-12

    Logged In: YES
    user_id=129364

    What is the exact error message about perl that you are
    getting when trying to install the .tar.gz version?

     
  • Logged In: NO

    Well I got it installed (yay, it much nicer than the older
    version I had) but only with the tar.gz version. I could
    never get the .rpm to install as noted in my original post.

    But all is well....you guys should add more stuff (local
    apache config and similar things) to Usermin too...that's a
    cool tool.

    But thanks - I'm installed

     
  • Jamie Cameron
    Jamie Cameron
    2002-05-31

    • status: open --> closed