#4187 Fedora 18 Login Page Error

1.610
open
nobody
None
5
2013-01-18
2013-01-18
No

I built a new machine with Fedora 18 and installed Webmin 1.610

After login, the status page displays the Webmin logo, and "Require package-updates/install_check.pl failed :Died at (eval 153) line 1." where the status info is expected.

I get the same results on another fresh Fedora 18 box, with Webmin 1.580

Discussion

  • Jamie Cameron
    Jamie Cameron
    2013-01-18

    Does anything get logged to /var/webmin/miniserv.error when this happens?

     
  • It barked about a missing perl-Authen-PAM, so I installed it. Now it's dying at line 156.

    /var/web/miniserv.error:

    [17/Jan/2013:19:24:56 -0600] miniserv.pl started
    [17/Jan/2013:19:24:56 -0600] Using MD5 module Digest::MD5
    [17/Jan/2013:19:24:56 -0600] PAM authentication enabled
    Error: Require package-updates/install_check.pl failed : Died at (eval 156) line 1.

    Error: Require package-updates/install_check.pl failed : Died at (eval 159) line 1.

    Error
    -----
    Require package-updates/install_check.pl failed : Died at (eval 159) line 1.

    -----

     
  • It must have something to do with the F18 perl-Authen-PAM rpm. Installing the rpm did not help, but running cpan install Authen::PAM did the trick

     
  • Jamie Cameron
    Jamie Cameron
    2013-01-18

    That is unusual, as the Authen::PAM perl module is only used to authenticate users when they login .. and is optional.