#4137 E: Unable to locate package libdigest-sha1-perl

closed-fixed
Jamie Cameron
5
2013-07-09
2012-09-09
Sam Vervaeck
No

Hi,

It seems like the latest version of ubuntu spawns an error in the installation script:
E: Unable to locate package libdigest-sha1-perl
when trying to run http://cloudmin.virtualmin.com/gpl/scripts/cloudmin-gpl-debian-install.sh

Apperantly, the package has been removed from Debian: https://bugs.launchpad.net/ubuntu/+source/libdigest-sha1-perl/+bug/993735

Greets,
Sam

Discussion

  • Sam Vervaeck
    Sam Vervaeck
    2012-09-09

    The installation script that has been used

     
  • Jamie Cameron
    Jamie Cameron
    2012-09-09

    • status: open --> closed-fixed
     
  • Jamie Cameron
    Jamie Cameron
    2012-09-09

    Thanks for pointing this out - please re-download the install script, and that package will no longer be a required dependency.

     
  • Harry Coin
    Harry Coin
    2013-07-09

    ldap users and groups has an sha1 related password problem. Notice if you put in a 'normal password' then hit save, the pre-encrypted password later displayed is merely {sha}
    I think you need to install libdigest-sha-perl and update the related modules.