#3803 change password -> pam_unix

1.520
closed-fixed
Jamie Cameron
5
2013-05-23
2010-11-19
No

Can't add a pam_unix module to any service.
After submitting the form, it reports this error:
"Failed to save module : Missing or invalid minimum password length"

Well of course it's missing... because the related fields are missing in the add pam_unix module form:
Minimum password length None
Maximum password length No limit
Prevent use of easy passwords? Yes No

They do show up when you are editing a existing pam_unix module though.

Discussion

  • using latest version 1.520

     
    • milestone: --> 1.520
     
  • Jamie Cameron
    Jamie Cameron
    2010-11-20

    Hmm, this works fine for me. Which specific service were you editing, and which step?

     
  • Usermin/Webmin and custom services.
    Debian 5.0.x

     
  • this bug still happens as of webmin 1.630 on debian 7.0

    maybe some linux component (passwdqc, pam, etc) or Webmin itself is requiring a minimum password length, which is not being supplied to the service?

     
  • Jamie Cameron
    Jamie Cameron
    2013-05-23

    Ok, I found the cause of this now - a fix will be included in Webmin 1.640.

     
  • Jamie Cameron
    Jamie Cameron
    2013-05-23

    • status: open --> closed-fixed