Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#3589 Required: /backup_config.pl failed

1.500
closed-fixed
Jamie Cameron
5
2010-01-19
2010-01-15
Michael Wegemer
No

Running Webmin 1.500 on Fedora Core 10 (i386 arch) with Firefox 3.0.15.

When trying to backup the webmin system itself through the menus, I get "Backup failed : require /backup_config.pl failed Died at (eval 396) line 1.

". The same thing happens when I schedule a backup and the scheduled attempt tries to run.

This bug has been reported twice before and resolved. The bug tracker gives no indication of what the resolution was. Please post resolutions to issues so that we do not have to go through the bug tracker process for things that are already resolved.

Discussion

1 2 > >> (Page 1 of 2)
  • Jamie Cameron
    Jamie Cameron
    2010-01-15

    Could you tell me exactly what settings you made on the backup form?

    I have been un-able to re-produce this bug ..

     
  • I highlighted all of the modules in the first box.
    I specified a local file /media/Share-sde/Backups/WebminBackup (the directory exists but the file does not)
    I checked the box for Webmin module configuration files
    Send Email to root
    Send Email always
    All other fields are blank

     
  • Jamie Cameron
    Jamie Cameron
    2010-01-16

    Sorry, but when I made the exact same selections, it works fine.

    Do you have any Webmin modules installed other than those that are part of the standard package?

     
  • I have already given you all of the settings that I have. There are no extra modules added to Webmin. I understand that the problem may not be reproducable as the same set up (different directory for saving) works on two other machines. The only difference I can determine is the level of Fedora. The failing machine is FC10 while the two that work are FC11. Could there be a difference in the versions of Perl. I am not a Linux expert by any stretch of the imagination but I can follow directions if you want me to try to get more debugging information or other information from my system for you.

     
  • Jamie Cameron
    Jamie Cameron
    2010-01-18

    One thing that would be useful is if you could edit the /etc/webmin/config file, and add the line :

    error_stack=1

    then re-try the backup, and send me the new full error message. It should include line numbers and perl filenames..

     
  • Failed to save backup : Require /backup_config.pl failed :

    Died at (eval 400) line 1.

    Call Stack Trace
    File Line Function
    ../web-lib-funcs.pl 2993 WebminCore::error
    /usr/libexec/webmin/bandwidth/backup_config.pl 4 WebminCore::foreign_require
    (eval 213) 1 (eval)
    ../web-lib-funcs.pl 2979 (eval)
    ./backup-config-lib.pl 307 WebminCore::foreign_require
    /usr/libexec/webmin/backup-config/save.cgi 71 backup_config::execute_backup
    (eval 35) 6 (eval)
    /usr/libexec/webmin/miniserv.pl 2145 (eval)
    /usr/libexec/webmin/miniserv.pl 753 miniserv::handle_request

     
  • Jamie Cameron
    Jamie Cameron
    2010-01-19

    backup-config.wbm.gz

     
    Attachments
  • Jamie Cameron
    Jamie Cameron
    2010-01-19

    Try installing the attached module update, at Webmin -> Webmin Configuration -> Webmin Modules. It should fix the problem ..

     
  • I can see that there is one attached file to this thread but I do not know how to get it. I am assuming when I do that I save it and use the local install function of the module updater.

     
  • Jamie Cameron
    Jamie Cameron
    2010-01-19

    Look down the bottom of the page in the "Attached File" section .. just click on the Download link.

     
1 2 > >> (Page 1 of 2)