#342 Undefined subroutine...

0.92
closed
Jamie Cameron
5
2002-12-31
2002-03-03
Anonymous
No

In Hardware-Partitions on Local Disks, the following
error message appears in the 'Partitions' panel:
Failed to list disks : Undefined subroutine
&proc::get_new_pty called at ./proc-lib.pl line 176.

It also seems unable to list the partitions on the scsi
channel, but is able to list those on the IDE channel..

I've been able to reproduce this without fail each time
I've tried..

Thanks!

Carl

Discussion

  • Jamie Cameron
    Jamie Cameron
    2002-03-04

    Logged In: YES
    user_id=129364

    What operating system and version are you running webmin
    on? That will help me try to re-produce this problem ..

     
  • Logged In: NO

    It's GNU/Sorcerer Linux (sorcerer.wox.org), using Perl
    v5.6.1....

    Since sorcerer isn't a configuration option, I'd chosen a
    different distro, but I'm unable to access that information
    at the moment.. if it'd be helpful, let me know and I'll get
    it..

     
  • Jamie Cameron
    Jamie Cameron
    2002-03-05

    Logged In: YES
    user_id=129364

    Does the Running Processes module work properly on
    your system? It may be that choosing a different
    distribution like that has messed webmin up ..

     
  • Logged In: NO

    Yes, the proc listing does work.. I had to reconfigre the
    module to display the output as a Linux 'ps' command would..

    I did experience an initial 404, but after poking around in
    the files to learn what file it was looking for and
    directing it to the index_tree.cgi file, it corrected
    itself.. That seems to have alleviated itself..

    Also, I've set the OS to be Red Hat 7.2.. I've had to make a
    few configuration changes (redirect the default file
    locations for a few services), but they've taken without
    incident...

     
  • danny hembree
    danny hembree
    2002-12-30

    Logged In: YES
    user_id=45072

    I get this message from MacOS 10.2.3. I set up an alternative
    password changing routine and put it's path into the module
    configuration. When I submit the password change I get this

    Undefined subroutine &proc::get_new_pty called at /Users/
    danny/Projects/usermin-0.980/proc/proc-lib.pl line 175.

     
  • Jamie Cameron
    Jamie Cameron
    2002-12-31

    • status: open --> closed
     
  • Jamie Cameron
    Jamie Cameron
    2002-12-31

    Logged In: YES
    user_id=129364

    This problem has been fixed (at least on OSX), and the fix
    will be included in the next webmin release..