#3233 No connection named "xxxxxx"

Other
closed-works-for-me
Jamie Cameron
5
2008-11-14
2008-11-11
BlueH2O
No

After creating a connection with this module, and then trying to start it, I get the message:
021 no connection named "xxxxx"

I have tried moving the config portion of ipsec.conf into ipsec.d/xxxxxx.conf but to no avail.
(default ipsec.conf contains "include /etc/ipsec.d/*.conf")

Discussion

  • BlueH2O
    BlueH2O
    2008-11-11

    ipsec does not seem to like webmin's "automatic" setting for address:

    022 connection must specify host IP address for our side
    037 attempt to load incomplete connection

    Fixing the .conf file gets rid of the error and allows the connection to be added, which in turn eliminates the "no connection named..." error.. Not sure what would be best to deal with this in webmin...

     
  • Jamie Cameron
    Jamie Cameron
    2008-11-14

    What fix did you make to the .conf file? Was it not having an automatic address for each 'side' of the connection?

     
  • BlueH2O
    BlueH2O
    2008-11-14

    My "fix" was to add the local IP. I'm not sure how 'automatic' is supposed to work, but the system definitely does not like not having it. I had hoped 'automatic' would account for the left's interface using DHCP from my ISP.

     
  • Jamie Cameron
    Jamie Cameron
    2008-11-14

    • status: open --> closed-works-for-me
     
  • Jamie Cameron
    Jamie Cameron
    2008-11-14

    In automatic mode, IPsec is supposed to work out your IP address .. but as to how it does this and what the limitations are, I can't say. All I know is that automatic is a valid option, so Webmin allows it :-)