Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#2383 Undefined Subroutine

1.250
closed-out-of-date
nobody
1
2006-02-14
2006-01-08
Fr3d
No

This while trying to view /software/index.cgi
HTTP/1.0 500 Perl execution failed Server: MiniServ/0.01 Date:
Sun, 8 Jan 2006 20:34:07 GMT Content-type: text/html Connection:
close
Error - Perl execution failed

Undefined subroutine &main::package_system called at /usr/
share/webmin/software/index.cgi line 25.

And this while trying to view /software/tree.cgi
HTTP/1.0 500 Perl execution failed Server: MiniServ/0.01 Date:
Sun, 8 Jan 2006 20:40:08 GMT Content-type: text/html Connection:
close
Error - Perl execution failed

Undefined subroutine &main::list_packages called at /usr/share/
webmin/software/tree.cgi line 11.

--
I've looked through CPAN using the Perl modules page, but I
found nothing that looks right... I install DPKG::Parse and every
one of it's dependancies but it didnt help.

Discussion

  • Fr3d
    Fr3d
    2006-01-08

    • priority: 5 --> 1
    • assigned_to: jcameron --> nobody
    • status: open --> closed-out-of-date
     
  • Fr3d
    Fr3d
    2006-01-08

    Logged In: YES
    user_id=1353999

    I deleted and redownloaded the module from the webmin site; now it
    works :D

     
  • Jamie Cameron
    Jamie Cameron
    2006-01-08

    Logged In: YES
    user_id=129364

    If you click on the Module Config link, make sure that the
    'Package management system' is set correctly (to Debian I
    presume).

    If that doesn't help, try using the tar.gz package of Webmin
    from www.webmin.com , instead of the Debian package
    installed with apt-get .

     
  • Jamie Cameron
    Jamie Cameron
    2006-01-08

    • status: closed-out-of-date --> open-out-of-date
     
  • Fr3d
    Fr3d
    2006-01-08

    Logged In: YES
    user_id=1353999

    Now why didn't I think of that! I guess when I reinstalled the module it
    detected it the right packaging system. And I always use the tar.gz
    package, as the debian/ubuntu one... sucks :P

    Thanks! :-)

     
  • Jamie Cameron
    Jamie Cameron
    2006-02-14

    • status: open-out-of-date --> closed-out-of-date