#2234 module for PostgreSQL V8.0 not working

1.220
closed
Jamie Cameron
5
2005-09-14
2005-09-07
Anonymous
No

SuSE 9.3 Professional and postgresql 8.0.3

It is not possible to handle the pgsql Database
with this webmin module.

I have a good and correct module config,
but i get always this message :

The PostgreSQL client program psql could not execute
on your system. Maybe PostgreSQL is not installed, or
your module configuration is incorrect.

The path is correct und pgsql is running well

the error Message occurs in webmin Version 1.220 and
also in the developer Version 1.225

Discussion

  • Jamie Cameron
    Jamie Cameron
    2005-09-08

    Logged In: YES
    user_id=129364

    What does the command pgsql -V output on your system,
    when it is run from the Command Shell webmin module? That is
    the command that is used to determine if the pgsql command
    is working OK ..

     
  • Logged In: NO

    This is the Output from webmin command shell

    pgsql -V
    sh: pgsql: command not found

    if i logged in with root it is the same
    and the user postgres didn't have it too

    Very funny ;-) thats SuSE

    I will check this in detail, but many thanks for your hint
    ( rpm packages , homepage of postgresql ...)

     
  • Jamie Cameron
    Jamie Cameron
    2005-09-08

    Logged In: YES
    user_id=129364

    Actually, the command should have been :
    psql -V
    Give that a try ..

     
  • Logged In: NO

    This is the output of the Command shell
    ( But the Error is still the same in Webmin )

    > psql -V ( locates in /usr/bin/ )
    psql (PostgreSQL) 8.0.3
    contains support for command-line editing

    Should i install the perl-DBD-Pg and perl-DBI rpm's ???

    If i install this perl-DB* , then the webmin postgresql starts
    without error , but the webmin didn't show my already running
    databases .

     
  • Jamie Cameron
    Jamie Cameron
    2005-09-13

    Logged In: YES
    user_id=129364

    That looks OK to me ..
    I have another question then - if you login to PostgreSQL
    manually with the psql command-line program and run the SQL :
    select version()
    what exactly does it output?

     
  • Logged In: NO

    I can solve It, with your hints,
    !!! Many thanks, it is working !!!

    My solutions is :
    -----------------------

    1.)
    You have to install this PERL-DBI-Pg rpm's

    2.)
    In the webmin-postgresql-config you have to
    edit the following lines:
    ---------------------------------------------------------------------
    Administration login : postgres

    AND (this causes the problems)

    Unix user to connect to database as: root !!!
    ( the default setup is not working )

    Encoding for database content: UTF-8

    Path to psql command: /usr/bin/psql

    ( Hint : I use the openexchange 8.0.5 Software )
    and the installation sripts creates this postgressql database
    openexchange under user 'root' and not under user 'postgres'

     
  • Jamie Cameron
    Jamie Cameron
    2005-09-14

    • status: open --> closed
     
  • Jamie Cameron
    Jamie Cameron
    2005-09-14

    Logged In: YES
    user_id=129364

    Ok, I'm glad this is solved. In future versions of webmin, I
    will make the error message in this case more relevant..