#1891 Cannot login to Webmin from FireFox (JS error)

1.170
closed
Jamie Cameron
5
2004-12-31
2004-12-30
Anonymous
No

When I attempt to login to Webmin (any of 3 different
servers) from a default install of Mozilla Firefox 1.0,
it will not let me login.

IE5/6 work fine for login.

Javascript Console shows the following error on the
login page:

Error: [Exception... "'Component does not have
requested interface' when calling method:
[nsIInterfaceRequestor::getInterface]" nsresult:
"0x80004002 (NS_NOINTERFACE)" location: "<unknown>"
data: no]

I have the latest WebMin 1.170 version installed with
mostly default settings. Since this happens on all 3
of our Webmin servers, I don't think its unique to our
setup.

Discussion

  • Logged In: NO

    Well, I *WAS* able to login to your demo site using Webmin
    1.170 from FireFox without an error, some Im confused what
    is different with my Webmin servers?

    You can contact me at chrisw@dq.com and I can provide
    temporary limited access for you to recreate this, or
    perhaps you have an idea what this could be?

     
  • Jamie Cameron
    Jamie Cameron
    2004-12-31

    Logged In: YES
    user_id=129364

    I really don't think this is a Webmin problem, since the
    login page is basically a simple form. It must be some
    firefox or client-specific bug ..

     
  • Jamie Cameron
    Jamie Cameron
    2004-12-31

    • status: open --> closed
     
  • Gilles Reeves
    Gilles Reeves
    2005-02-04

    Logged In: YES
    user_id=512471

    I had the same problem with Firefox trying to login on Webmin
    (I use 1.150 now).

    After some search, I think this is a cookie problem.
    In fact, I found that Firefox works fine with Webmin after
    deletion of all its cookies related to Webmin.

    So I wondered why I got bad cookies BEFORE any use of
    Webmin from Firefox.

    The reason is probably because Firefox, on installation,
    imports (by default) all cookies from Internet Explorer.

    After making Firefox working with Webmin by deleted cookies,
    I checked this by importing (again and manually) all cookies
    from IE to Firefox: after that, Firefox was not able again to
    login on Webmin.

    So I suppose there is a problem in the Firefox module for
    importing cookies, but I am wondering anyway if it is normal
    that Webmin get stuck with such "bad" cookies?

    That's why I give you here some samples of cookies sent to
    Webmin (captured using Ethereal) with the "POST" request
    created by the login form :

    **Not working cookie sent to Webmin by Firefox:
    Cookie: sid=72eb6416c52a760a17cb7a63aa2ff975;
    sid=bb20fce19e3c6b946c6ecdfe75a7e7de; testing=1

    **After "repair", a working cookie sent to Webmin by Firefox:
    Cookie: testing=1; sid=3eb0f85be84a89554fbc7826fd6d70f3;
    user=x

    **Cookie (working, of course) sent to Webmin by Internet
    Explorer 6.0:
    Cookie: sid=24b5981ee013914317bd0bf16d67b120; user=x;
    testing=1

     
  • Logged In: NO

    I have the same problem