Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#12 Bug with Squid 2.4 STABLE1

All
closed
Jamie Cameron
5
2001-04-23
2001-04-11
Anonymous
No

Webmin Display "Your Squid cache directory has not
been initialized.This must be done before Squid can be
run." but Can set every things except Apply Changes &
Stop Squid It's have only Initail Cache Botton

Discussion

  • Jamie Cameron
    Jamie Cameron
    2001-04-12

    • status: open --> closed
     
  • Jamie Cameron
    Jamie Cameron
    2001-04-12

    Logged In: YES
    user_id=129364

    That's normal , assuming you have never used squid before.
    Just select a user and click the 'Initialise cache' button
    to set squid up
    properly ..
    However, if squid is already running properly on your system
    then this
    is a bug in webmin.

     
  • Logged In: NO

    I'm Alredy Clickclick the 'Initialise cache' & use Command
    squid -k ... but It's Still diplay Message.

    & I'm use squid 2.4 Prestayble before I'm only update to 2.4
    Stable 1

    & My squid alreay run normaly.

    Please try with your self before answers.

     
  • Logged In: NO

    I'm Alredy Clickclick the 'Initialise cache' & use Command
    squid -k ... but It's Still diplay Message.

    & I'm use squid 2.4 Prestayble before I'm only update to 2.4
    Stable 1

    & My squid alreay run normaly.

    Please try with your self before answers.

     
  • Logged In: NO

    I'm Alredy Clickclick the 'Initialise cache' & use Command
    squid -k ... but It's Still diplay Message.

    & I'm use squid 2.4 Prestayble before I'm only update to 2.4
    Stable 1

    & My squid alreay run normaly.

    Please try with your self before answers.

     
  • Jamie Cameron
    Jamie Cameron
    2001-04-13

    Logged In: YES
    user_id=129364

    Maybe you could email you squid.conf file to me at
    jcameron@webmin.com
    There is probably something in there that webmin doesn't
    understand ...
    Also, what does squid -v output on your system?

     
  • Jamie Cameron
    Jamie Cameron
    2001-04-13

    • status: closed --> open
     
  • Logged In: NO

    Jamie:

    I beleive the problem is with the cache_dir option, as per
    documentation in Squid Home page, the cache_dir should be
    like this:

    cache_dir Type Maxobjsize Directory-Name Mbytes Level-1
    Level2

    but in the squid.conf file itself it say like this:

    cache_dir Type Directory-Name Mbytes Level-1 Level2

    so NO Maxobjsize. If I put Maxobjsize my squid don't start
    with error message, if I remove Maxobjsize then it works
    ok, but webmin show the Initialization button.

    Webmin Squid module 0.84 (without the Maxobjsize) works
    perfect with Squid. Don't beleive is a Squid 2.4S1 problem
    only.

    Hope this helps

     
  • Logged In: NO

    Jamie:

    I beleive the problem is with the cache_dir option, as per
    documentation in Squid Home page, the cache_dir should be
    like this:

    cache_dir Type Maxobjsize Directory-Name Mbytes Level-1
    Level2

    but in the squid.conf file itself it say like this:

    cache_dir Type Directory-Name Mbytes Level-1 Level2

    so NO Maxobjsize. If I put Maxobjsize my squid don't start
    with error message, if I remove Maxobjsize then it works
    ok, but webmin show the Initialization button.

    Webmin Squid module 0.84 (without the Maxobjsize) works
    perfect with Squid. Don't beleive is a Squid 2.4S1 problem
    only.

    Hope this helps

     
  • Babak Farrokhi
    Babak Farrokhi
    2001-04-22

    Logged In: YES
    user_id=86244

    Jamie,

    I think that's a bug. I already submitted a bug report
    (seemd to be lost in new changes) and reported the same bug.
    With the new style of cache_dir in squid 2.4, webmin does
    not recognize whether then cache directory is initialized or
    not,and also does not show the correct configuration in
    "cache directory" configuration.
    I will send a copy of my squid.conf by email.

    Thanks,
    Babak

     
  • Jamie Cameron
    Jamie Cameron
    2001-04-23

    • status: open --> closed
     
  • Jamie Cameron
    Jamie Cameron
    2001-04-23

    Logged In: YES
    user_id=129364

    An updated module that fixes this problem has been uploaded
    to
    http://www.webmin.com/webmin/updates.html