Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Mesh not forming

Help
thor101
2007-01-10
2013-04-17
  • thor101
    thor101
    2007-01-10

    I set up waste, and installed it on multiple computers all on a private rfc1819 network.  Many of these computers are on the same switch.  The problem is that they aren't forming a mesh.  All the computers in the network can connect to my computer, and I can connect to every one else's (by entering in their IP address in the network connect box).  And if the other users manually enter in the IP address of other users, they can also connect.  It just seems like the auto-mesh feature doesn't work.

    I'm wondering if there might be a broadcast issue that isn't working properly (or is being denied by my switch?!?)  I couldn't find any documentation on the protocol that waste uses for creating the mesh.  Other than in the code, is there anyplace this is documented?

    Can anyone offer a few quick "check this out" to see what might be happening?

    Thanks.

    --thor101

     
    • thor101
      thor101
      2007-01-10

      So I did some more testing.  All of this is on a closed network.  So 4 windows machines plugged into a switch, no firewalls.

      If I run the system with 192.168.20.* addresses, it doesn't work.  If I pick a routable network at random: 15.15.20.* then the connections are made, and the mesh starts working.

      I checked the "Your IP Addr."  If it is set to Auto, nothing appears in the box.  If I set it to forced (192...) it doesn't work.  If I set it to Normal, it still doesn't work.  The odd thing is that if I enter ins omething into forced, then I click on Auto, it just takes the IP address from forced... Not very auto.

      The only way I can get it to work is by setting the IP address of all the machines to 15.15.20.*

      Any suggestions?

       
      • Starlionblue2
        Starlionblue2
        2007-01-10

        Interesting. I use Waste in my home network (10.0.0.0 subnet) but it is also routed over the Internet without issues. I do not use the "force" option. I have not seen this problem at all.

         
    • thor101
      thor101
      2007-01-10

      So I think I may have found the problem.  Oh, by the way, I am running these all on Windows XP.

      bool IPv4IsPrivateNet(unsigned long addr)
      {
          bool t;
          t=IPv4TestIpInMask(addr,IPv4Addr( 10,  0,  0,  0),IPv4NetMask( 8));if (t) return true;
          t=IPv4TestIpInMask(addr,IPv4Addr(172, 16,  0,  0),IPv4NetMask(12));if (t) return true;
          t=IPv4TestIpInMask(addr,IPv4Addr(192,168,  0,  0),IPv4NetMask(16));if (t) return true;
          return false;
      }

      I think what happens is that some message creation subroutine calls this guy to see if the address is private.  if it is, it doesn't send out the "Hello I'm here" message.

      I can't really tell for sure since all the messages are encrypted (otherwise I would have just turned wireshark on it to see what was happening).  I tried the log files, setting the level to 5, but that still didn't seem to tell me much.

      I don't have a compiler myself, so I asked one of my friends to put the return false; as the first line, recompile and send it back.  I'll let you know if that fixes it.

      --t

       
    • thor101
      thor101
      2007-01-10

      Looks like it might be a couple of things.

      First of all, make sure that your "Maintain X connections" is set to a number other than 0.  That wasn't my problem, but it could be for anyone else having this issue.

      Next, File -> Prefs -> Networking -> Your Ip Addr.  Set it to Normal, direct internet connection.
      Next, File -> Prefs -> Networking -> Access Control -> Use, Add, Ok

      You should now see the mesh get created.

      Good luck.

      --t