Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Wallpaper doesn't change in Gnome Classic

Help
poo706
2011-09-11
2013-04-24
  • poo706
    poo706
    2011-09-11

    Ubuntu 11.10, Gnome Classic, Compiz/Metacity (tried both), Wally 2.4.2

    I was hoping that once Wally supported Gnome Shell that Gnome Classic would work, but alas, no.  The program loads, there's a tray icon, I can see the CPU jump for a little while when I select next picture, but the wallpaper never changes.  Wallch for Gnome 3 does switch the wallpaper correctly, but it is much too simple compared to Wally.

     
  • Hi,

    first of all, just consider that Wally is not compatible with Compiz, as long as Compiz handles background change.

    Anyway, please launch "wally -debug" from command line, and send me your log. We can inspect it and find out what's wrong.

    Thanks,
    Tony.

     
  • poo706
    poo706
    2011-09-13

    Wally isn't compatible with Compiz?  That's ok, I'd rather use Metacity anyway.  I ran Wally - debug, let it sit for a bit, then did a next wallpaper, then ^C to quit.  The log was pretty long, so I put it up on Pastebin: http://pastebin.com/uxNRaUD2 .  Thanks for the timely reply.

     
  • Hi,

    I'm really sorry cause I didn't have time to answer you in past days, I didn't have a usable Internet connection.

    I've just inspected your log. Wally detects Gnome classic environment, and it sets the image. This means that your environment (and I don't know why) does not accept background change.

    As a proof of that, please choose an image and type the following commands:

    gconftool-2 -type bool -set /desktop/gnome/background/draw_background true
    gconftool-2 -type string -set /desktop/gnome/background/picture_options centered
    gconftool-2 -type string -set /desktop/gnome/background/picture_filename the_filename_you_have_chosen

    Obviously, substitute the last parameter with the filename of your image.

    If your wallpaper changes, than it's a Wally's bug, and it needs to be inspected further. If it doesn't change, your window manager handles wallpaper change, and it's not a WM that Wally normally handles. Even if you think that Metacity is fine, maybe there's another running process that handles wallpaper change and does not allow Wally to access that.

    Please confirm your test, in order to go on debugging.

    Thanks,

    BR,
    Tony.

     
  • poo706
    poo706
    2011-09-18

    Don't sweat it on the delay, I appreciate you taking the time.  The commands provided did not change the wallpaper.  Nor was there any output, good or bad, after each command.

     
  • Well, in this case there's no way to change your wallpaper by Wally. This means you're using a window manager that "looks like" Gnome, but it doesn't support wallpaper change via command line. Or you're using a compatible window manager, but something is locking the change.

    In case you find out a command line that is able to change your wallpaper, please report it to me, and I'll add your environment support too.

    BR,
    Tony.

     
  • poo706
    poo706
    2011-09-19

    I decided, for S's & G's, to try out a line from toutatis2003's post here: http://sourceforge.net/projects/wally/forums/forum/848087/topic/4611448 .  Entering this command DID in fact change the wallpaper:

    gsettings set org.gnome.desktop.background picture-uri "file:///path/to/pic.jpg"

    Isn't this the change made in 2.4.2 in order to get Wally working with Gnome Shell?  Is Wally incorrectly detecting Gnome 3 Classic as Gnome 2?

     
  • Hi,

    you can force a window manager launching Wally via command line in the following way:

    wally -forcewm GnomeShell

    Can you try to force GnomeShell and see if it works?

    In any case, can you please post me the output of this command? "ps auxw"

    Thanks,
    Tony.

     
  • poo706
    poo706
    2011-09-21

    Forcing GnomeShell worked!

    Here's the output of "ps auxw": http://pastebin.com/Em3RPXUh .

     
  • Damn … that's a real BIG problem.

    The list of your processes almost matches the one that has old Gnome wallpaper system. So there's no way to find out which kind of Gnome version you have.

    If you use pure Unity, you have a "GnomeShell" process running, that makes me realize that you're using the new way.

    I'll try to Google around to find out if it's possible to detect it in a different way. Otherwise, I'll have to launch both commands in both detection, hoping that they won't interfere each other (I don't care if one of two fails).

    Please, if you find out a way to detect your environment, report it to me, it'll be very useful.

    Thanks,
    Tony.

     
  • poo706
    poo706
    2011-09-22

    To get old school panels back in Gnome 3, I had to install gnome-session-fallback, which appears to be a new package starting with Ubuntu 11.10.  What if Wally checked to see if this package is installed AND checked to see if gnome-panel is running?  Gnome 2 users would have gnome-panel running, but wouldn't have the fallback package.  Gnome 3 users may have the fallback package installed, but if they're logged in with Unity or Gnome Shell, I wouldn't think gnome-panel would be running.  And of course, Gnome 3 Classic users would have both the fallback package and gnome-panel running.

     
  • Hello Tony,

    I recently upgraded my Ubuntu on Oneiric and Wally doesn't change the wallpaper untill i'm using your command line: wally -forcewm GnomeShell.

    LGDN.

     
  • But some functionnality are disabled: next picture, previous picture and save as are grayed…

     
  • Hi,

    @poo706: detecting packages will connect Wally behavior to a specific platform, and I don't want to pollute Wally's code with lengthy specific stuff. Moreover, it will be related to apt output, and I cannot connect Wally detection to a program output that can change in future (and it's language - dependent).

    I still think that calling both commands will be the quick and easy solution

    @legluondunet: yes, for the same reason that poo706 found, at the moment you need to force GnomeShell detection.

    About the second problem, I cannot understand what you mean? Can you please specify your actual settings in detail, maybe posting also a snapshot?

    Tony.

     
  • poo706
    poo706
    2011-09-29

    I totally understand that you don't want to make Wally Ubuntu-specific.  If I have to tack on a command-line option to make it work, I can certainly live with that.  I'm just glad Wally is still functional.  By the way, the option that I appreciate the most is to scale down images larger than the desktop while not scaling up images smaller than the desktop.  I asked the Wallch devs if this option could be added to Wallch and I was told that Gnome can't do that, so Wallch can't do that.  Then the post was marked as "answered" and I never heard anything else from them despite asking more questions.  I really appreciate your willingness to work with Wally's users.

     
  • Hi,

    thanks so much for your understanding :) … and, well … I also had some … problems with Wallch creator's unpolite behavior! :) …

    Anyway, I need your help. If I prepare an Ubuntu package with the double Gnome command, would you like to help me test it before releasing a patch for this issue? Better, if I give you the source, can you compile them by yourself?

    If so, please write me at tony@becrux.com, and we'll discuss the procedure.

    Thanks so much in advance.

    BR,
    Tony.

     
  • poo706
    poo706
    2011-10-02

    I emailed you a couple of days ago, FYI.

     
  • Juuliusgee
    Juuliusgee
    2011-10-19

    Hi!
    i've tried your force command but it didn't work

     
  • Dueller
    Dueller
    2011-10-23

    Hello Tony.
    Under 11.10 Oneiric I had the same problem described above (wally did not change wallpaper) but the "-forcewm GnomeShell" did the trick.
    The only other problem is that some options are no more available (greyed out).
    Here is a screenshot of the tray window:


     
  • Hi,

    you should start Wally with "Riproduci", to enable such options.

    Tony.

     
  • Beugul
    Beugul
    2011-10-27

    Hi,

    you should start Wally with "Riproduci", to enable such options.

    Tony.

    I'm having the same problem as dueller but your "Riproduci" command won't work for me. Also, my version is in English.

     
  • Dueller
    Dueller
    2011-11-05

    Hi, you should start Wally with "Riproduci", to enable such options. Tony.

    After a reboot it did the trick… thank you!