Problem building latest release on Linux

  • Hi,

    I tried compiling the latest release ( as well as the current code at the git repository) on Ubuntu Server 12.04 LTS 32 bits, but it stops with this error:

    make: *** No rule to make target ../../obj/GClasses/dbg/G3D.o', needed by../../lib/GClassesDbg.a'. Stop.

    I proceeded to compile the previous version ( on the same system, and it worked perfectly. I checked the latest version on Windows and it also works.

    This suggests to me that there may be a problem in the Makefile of the latest version. Any help would be great.


  • Anonymous

    I cannot seem to repro this issue. I suspect the problem is that waffles/obj/GClasses/dbg/G3D.d was generated improperly. I think that it will fix it if you delete the waffles/obj folder and rebuild. If that does not fix it, let me know, and I can give more explicit instructions about how I would debug it. Good luck!


  • Anonymous

    Same issue here can't install on ubuntu 12.04 LTS 64 bit

    make: *** No rule to make target ../../obj/GClasses/dbg/G3D.o', needed by../../lib/GClassesDbg.a'. Stop.

    Installed the which will fit my need just fine.

  • Mike Gashler
    Mike Gashler

    Hmm, I develop on Ubuntu 12.04 LTS 64-bit, so it is surprising that I have not seen this issue.

    The rule to make that target should be found in waffles/obj/GClasses/dbg/G3D.d, which should look something like this:

    ../../obj/GClasses/dbg/G3D.o: G3D.cpp G3D.h GError.h GRand.h GDom.h GHeap.h GMath.h GImage.h \ GVec.h
    g++ -Wall -g -D_DEBUG -c G3D.cpp -o ../../obj/GClasses/dbg/G3D.o

    Does yours look like that? If you delete this file, it should just regenerate it. Does that help at all?



Cancel   Add attachments