From: Ian Scott <ian.scott@st...> - 2002-10-04 09:58:59
We have had several suggestions for a better name for vil2_image_data.
This class is a bit like the old vil_image_impl, in that you can do a
get_view, put_view (equivalent to get_section and put_section) on it, and
you can wrap it in other vil2_image_data objects which pipeline the
get_view, put_view method calls.
The problem is that the existing name suggests that the object is the real
image data in memory (or elsewhere) which a vil2_image_view looks at.
Suggest others or vote please for
A. vil2_external_image - AWF's favourite
B. vil2_image_resource - my favourite.
C. vil2_image_holder - Tim's favourite.
From: Ian Scott <ian.scott@st...> - 2002-10-07 12:03:23
> From: Ian Scott
> We have had several suggestions for a better name for vil2_image_data.
> Suggest others or vote please for
A. vil2_external_image 1
B. vil2_image_resource 3
C. vil2_image_holder 1
D. vil2_file_image 0
E. vil2_large_image 0
F. vil2_source_or_sink 0
So, I will convert vil2_image_data to vil2_image_resource.