In addition to GLUT, OS X includes wxWidgets -- at least 10.4 does, I'm not sure about earlier versions.  Moreover, the FindwxWidgets.cmake file included in VXL seems to work correctly on OS X.  However, the last time I tried to compile VXL with VGUI enabled, the wxWidgets implementation needed a lot of patching to satisfy the gcc variant on OS X (most changes involved unicode strings).  Finally, there were bugs in earlier versions of CMake for getting VGUI-based applications to run properly (either from the command line or double clicking in the finder).  I don't know whether these have been fixed in the latest release or not.

That being said, I use VXL on OS X by compiling the core and contributed libraries via 'cmake' and 'make' with the terminal, and disabling VGUI and FFMPEG.  I believe there are one or two warnings from gcc, but for the most part, everything compiles and links cleanly.  I use XCode, Interface Builder and QuickTime as substitutes for VGUI and FFMPEG.  In general, it's fairly easy to wrap CVPixelBuffers into vil_image_views, as long as you are happy with interleaved byte format.  Using packed formats like vil_rgb and vil_rgba will usually require copying the data from the CVPixelBuffer.

Hope that helps,

Peter


On 14/12/2007, at 9:35 AM, Amitha Perera wrote:

Tobias,

As far as I know, none of the "regular" developers have a MacOS system 
to debug on, so it's difficult to help.  (Who knows, maybe someone will 
chime in now.)

What gui toolkit is used on the Mac?  glut?  gtk?  Something else?

Amitha.



Tobias Wood wrote:
Hi everyone,
I'm a fairly new (~3 months) user of VxL. At work I am developing on  
Windows and MS Visual Studio, but over the last couple of days I have been  
setting up VxL on my Mac Mini so I can work from home. I had a couple of  
issues whilst compiling VxL (Trying to find the OpenGL libraries on Tiger  
was fun!), and to get my project to link properly I had to turn off  
ZeroLink in XCode, but now I can actually compile and run VxL code.
However, part of my project uses an image deck to display some images.  
When my code actually gets to the vgui section, the following error  
message is sent continually to the console until the vgui window is closed:
vgui_test_events[319] Exception raised during posting of notification.   
Ignored.  exception: *** -[NSCFString  
replaceCharactersInRange:withString:]: Range or index out of bounds
This behaviour is also replicated in the test programs in  
vxl/bin/core/vgui/tests/ (Hence the vgui_test_events part at the start of  
that pasted line). This is not a fatal error, but it is annoying! The  
exception gets raised several times a second and quickly fills up the  
console window.
Does anyone have any idea how to stop this error happening? Is it  
something to do with how I have compiled VxL? Any help is much  
appreciated, this is a bit beyond my level of experience.
Thanks,
Toby

System info:
Intel Mac Mini 1.66 Core Duo
2 Gigs RAM
VxL 1.9.0
XCode 2.4.1
i686-apple-darwin8-gcc-4.0.1

-------------------------------------------------------------------------
SF.Net email is sponsored by:
Check out the new SourceForge.net Marketplace.
It's the best place to buy or sell services for
just about anything Open Source.
http://sourceforge.net/services/buy/index.php
_______________________________________________
Vxl-users mailing list
Vxl-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/vxl-users



-------------------------------------------------------------------------
SF.Net email is sponsored by:
Check out the new SourceForge.net Marketplace.
It's the best place to buy or sell services
for just about anything Open Source.
http://ad.doubleclick.net/clk;164216239;13503038;w?http://sf.net/marketplace
_______________________________________________
Vxl-users mailing list
Vxl-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/vxl-users