Hi Sean,

I do have plans to bring libpng 1.5 into v3p, but it may take me a few weeks. 

vil1 seems to be affected as well.  Taking this chance,  I wonder how many people are still using vil1.  If few people do, I may consider not to upgrade vil1.

Gehua Yang.

On Wed, Mar 28, 2012 at 2:39 PM, Sean McBride <sean@rogue-research.com> wrote:
On Thu, 1 Dec 2011 11:56:54 -0500, Sean McBride said:

>>For a while my dashboard has been having errors:
>>error: member access into incomplete type 'png_info' (aka 'png_info_def')
>>    rows = new png_byte* [info_ptr->height];
>>                                  ^
>>/usr/X11R6/include/png.h:692:16: note: forward declaration of 'png_info_def'
>>typedef struct png_info_def png_info;
>>               ^
>>The problem is that it is deciding to use png.h from /usr/X11R6/include
>>instead of the png.h within vxl itself.  If I set VXL_FORCE_V3P_PNG then
>>it builds.
>>Why is it deciding to look in /usr/X11R6?
>Hi again everyone,
>Someone pointed me to this offlist:
>and I think I've found the change to the machine that started to make
>this test fail, it was probably Apple Security Update 2011-006:
>which updated Lion's X11 to libpng 1.5 to fix security vulnerabilities.
>The conclusion is that vxl is not compatible with libpng 1.5 and vxl
>should be updated to be compatible or at least detect that it has auto-
>found an incompatible libpng.

Hi all,

Is there any news on this issue?

Will vxl be updated to be compatible with libpng 1.5?


Sean McBride, B. Eng                 sean@rogue-research.com
Rogue Research                        www.rogue-research.com
Mac Software Developer              Montréal, Québec, Canada

This SF email is sponsosred by:
Try Windows Azure free for 90 days Click Here
Vxl-users mailing list