Jim, I cannot help you now but from my experience of building vxl (all versions prior 1.12), VS 2008 has no problem when building vxl. I did this on both my Win XP desktop and Win Vista laptop. I use CMake 2.6.0.
 
> Date: Wed, 1 Apr 2009 17:07:52 -0400
> To: vxl-users@lists.sourceforge.net
> From: jgreen@robotvision.com
> Subject: Re: [Vxl-users] Linker problem with vbl, vul, vpl when compiling target ALL_BUILD under XP and MS VS2008
>
> I have been waiting for someone else to post a definitive explanation
> for this problem, but since no one has yet, let me add my
> experience/problems with VS2008.
>
> Several months ago I decided to upgrade my systems from Win2000 to
> WinXP SP2, (I had not upgraded until then following the "if it's
> not broken, don't fix it" rule.) I had a new 250GB SATA-2 disk, so I
> added that and installed XP on it. I also had a free copy of Visual
> Studio 2008 (which doesn't install on Win2000) that I wanted to use,
> so I installed that. I also had to download and install the more
> recent version of CMake to work with VS2008.
>
> I could not get VXL to build under VS2008. (Unfortunately I didn't
> keep a record of the errors produced.) But it turned out that this
> new disk died from infant mortality, and I assumed that the VS2008
> problems were associated with errors written on the failing disk.
>
> About a month later that disk was replaced by the manufacturer, and I
> started over and installed WinXP, VS2008 and the new version of CMake
> and tried again to build VXL. Unfortunately, build errors
> remained. I'm not sure if they were exactly the same errors and
> again I did not write them down. At that point I just abandoned
> VS2008, uninstalled it, installed my old version of VS2005, and VXL
> built with no problems.
>
> So my input here is there may be some bugs in VS2008 which cause
> building VXL to hiccup. So Roland is not the only one who has had a
> problem. Sorry I didn't make a copy of the circumstances and errors
> produced, I just wanted to get back to something that worked.
>
> Regards, Jim Green
> ----------------------------------------------------
>
> At 09:25 PM 3/29/2009, you wrote:
> >Roland Goecke wrote:
> > > just to make sure, I did all you suggested again, but I still end up
> > > with linker errors, although there are this far more than before:
> >[...]
> > > On a positive note, the vbl.lib, vpl.lib and vul.lib were built
> > > automatically this time.
> >
> >Hmmm. Different errors => non-deterministic => something non-obvious is
> >going on.
> >
> >Could someone with VS 2008 try to reproduce the same problem that Roland
> >is having?
> >
> >Meanwhile, I'll look into the log you sent me (in a separate email).
> >
> >Thanks,
> >Amitha.
>
>
> ------------------------------------------------------------------------------
> _______________________________________________
> Vxl-users mailing list
> Vxl-users@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/vxl-users


更多热辣资讯尽在新版MSN首页! 立刻访问!