Did you reindex all of your records after step 2?

If it's not that simple, have you tried turning on debug to see what kind of queries are being generated by VuFind? That might offer a clue or point of departure for experimentation with manual query generation.

- Demian

From: Shepard, Thomas - 1150 - MITLL [tshepard@ll.mit.edu]
Sent: Friday, April 18, 2014 4:24 PM
To: vufind-tech@lists.sourceforge.net; vufind-general@lists.sourceforge.net
Subject: [VuFind-Tech] Making new marc fields searchable

I am trying to include our 035 field searchable as part of our isbn searches.

I have no problem setting up a facet with values from 035, and I can configure the search dropdown options to include this field, but I get no hits back then I search on values from this field.

After perusing the web, I came across responses to Mansur Ali’s similar question and so also edited searchspecs.yaml to include this field.

Oh, and yes, 035 is also our ID field, but we have multiple 035 fields in any given record and our vufind importer takes the first one.

 

In summary, I did the following:

1.       In schema.xml, I created a ctrlnum field with type=”string” indexed=”true” stored=”true” multivalued=”true”

2.       In marc_local.properties, I defined ctrlnum as ctrlnum = 035a, (pattern_map.id)

3.       In search.ini, I defined ctrlnum=”Control035”

4.       In searchspecs.yaml, I added ctrlnum as follows:

ISN:

  DismaxFields:

    - isbn

    - issn

    - ctrlnum

  QueryFields:

    issn:

      - [and, 100]

      - [or, ~]

    isbn:

      - [and, 100]

      - [or, ~]

    ctrlnum:

      - [and, 100]

      - [or, ~]

 

Am I missing a step?

Oh, I also tried this by changing ctrlnum to type=”isn” but still no search results unless I search for an isbn (from the 020 field)

 

Thanks in advance,

Thom Shepard

 

Thom Shepard

MIT Lincoln Lab
244 Wood St.

Lexington, MA 01523

tshepard@ll.mit.edu

781 981 0370781 981 0370