Is this an indexing problem?  VuFind's Solr id field should correspond with your ILS's bibliographic record identifier.

(Sorry if I'm misunderstanding what you're saying -- not familiar with the Symphony title/record ID distinction).

- Demian

From: Gregory M. Testa [gmtesta@infopeake.org]
Sent: Friday, August 23, 2013 2:07 PM
To: Demian Katz; vufind-general@lists.sourceforge.net
Cc: vufind-tech@lists.sourceforge.net
Subject: RE: VuFind Symphony Web Services Question

Thanks, Demian.

So far, I see that the check_item_statuses.js routine is using the record id rather than the title id to lookup title info.

Iím continuing to research.

 

Regards,

Gregory

 

From: Demian Katz [mailto:demian.katz@villanova.edu]
Sent: Friday, August 23, 2013 7:19 AM
To: Gregory M. Testa; vufind-general@lists.sourceforge.net
Cc: vufind-tech@lists.sourceforge.net
Subject: RE: VuFind Symphony Web Services Question

 

I'm copying this to the vufind-tech list to reach a wider audience.

Unfortunately, I'm not familiar with Symphony, so I don't have specific advice...  but have you tried adding some debug statements to the makeRequest method of the Symphony driver to find out more about what is happening?  A well-placed error_log or two might help you find out what API requests are being made and discover if there are problems with bad IDs being sent in, etc.

If you find any more clues, feel free to share them here.

Good luck!

- Demian


From: Gregory M. Testa [gmtesta@infopeake.org]
Sent: Thursday, August 22, 2013 4:18 PM
To: vufind-general@lists.sourceforge.net
Subject: [VuFind-General] VuFind Symphony Web Services Question

 

Iíve got VuFind up and running and I have established connectivity with Symphony using the web services driver.  Iím able to authenticate and view my account info, holds, my profile etc.  Iím not able to get my real-time holdings: call numbers, locations and availability.

 

I am seeing this error in my symws.log file:

2013-08-22 15:17:18,194 [http-bio-8080-exec-6] ERROR [com.sirsidynix.symws.service.standard.impl.HatStandardService] Display1Item failed due to (ITEM $(9)) : ITEM Database error--unable to process request

 

In Firebug, I am seeing the following:

{"data":[{"id":"ocn833630459","availability":"false","availability_message":"<span class=\"checkedout\">Checked Out<\/span>","location":"Unknown","locationList":false,"reserve":"false","reserve_message":"Not On Reserve","callnumber":"","missing_data":true,"record_number":0}

 

My Environment:

VuFind 2.01

Symphony 3.4.1.3

Web Services v3_2_2699 2011-11-22 16:22:43

 

I appreciate any help you can provide.

 

Best Regards,

Gregory Testa

Systems Analyst II

CPL Information Systems

757-410-7174

gmtesta@infopeake.org