Sounds like you don't have PHP's SOAP extension installed/enabled.  See this thread for some details:

http://stackoverflow.com/questions/11391442/fatal-error-class-soapclient-not-found

- Demian

From: Crimi, Nick [CRIMIN@ecu.edu]
Sent: Monday, August 19, 2013 12:26 PM
To: Demian Katz; vufind-general@lists.sourceforge.net
Subject: Re: Symphony driver for vufind

The apache error log is finally showing some love.  It says that PHP Fatal error:  Class 'SoapClient' not found in C:\\vufind\\module\\VuFind\\src\\VuFind\\ILS\\Driver\\Symphony.php on line 138

Nick 

From: Demian Katz <demian.katz@villanova.edu>
Date: Saturday, August 17, 2013 7:17 AM
To: Microsoft Office User <crimin@ecu.edu>, "vufind-general@lists.sourceforge.net" <vufind-general@lists.sourceforge.net>
Subject: RE: Symphony driver for vufind

Does it help to put the password value in quotes in the .ini file?  It looks like PHP is having trouble parsing the file, so you should be able to fix by adjusting the syntax of your .ini.

- Demian

From: Crimi, Nick [CRIMIN@ecu.edu]
Sent: Friday, August 16, 2013 4:16 PM
To: Demian Katz; vufind-general@lists.sourceforge.net
Subject: Re: Symphony driver for vufind

After clicking on an item I get the backtrace and previous exceptions.  It doesn't like the password on line 13 in the driver ini.  Maybe php needs to escape a special character?  I have attached the full error.

NIck

From: Demian Katz <demian.katz@villanova.edu>
Date: Friday, August 16, 2013 3:56 PM
To: Microsoft Office User <crimin@ecu.edu>, "vufind-general@lists.sourceforge.net" <vufind-general@lists.sourceforge.net>
Subject: RE: Symphony driver for vufind

Are there “previous exceptions” that offer more clues?  The failure to build the symphony driver may be a side effect of some deeper problem (for example, I think the Symphony driver depends on the cache manager, so if your cache directory permissions are wrong, that could cause the problem).

 

- Demian

 

From: Crimi, Nick [mailto:CRIMIN@ecu.edu]
Sent: Friday, August 16, 2013 3:55 PM
To: Demian Katz; vufind-general@lists.sourceforge.net
Subject: Re: Symphony driver for vufind

 

Thank you Demian.  That gives me the error message An abstract factory could not create an instance of symphony(alias: Symphony).  Is it more likely that the ILS is misconfigured or a mistake in the symphony.ini ?

 

-Nick

 

From: Demian Katz <demian.katz@villanova.edu>
Date: Friday, August 16, 2013 2:21 PM
To: Microsoft Office User <crimin@ecu.edu>, "vufind-general@lists.sourceforge.net" <vufind-general@lists.sourceforge.net>
Subject: RE: Symphony driver for vufind

 

To get more details, you can turn on development mode by uncommenting the relevant line in http-vufind.conf and restarting Apache.

 

- Demian

 

From: Crimi, Nick [mailto:CRIMIN@ecu.edu]
Sent: Friday, August 16, 2013 11:01 AM
To: vufind-general@lists.sourceforge.net
Subject: [VuFind-General] Symphony driver for vufind

 

I'm trying to use the Symphony driver for vufind 2.0.1 in windows and have run into errors.  I set the baseURL, clientID, user and password.  The clientID matches the one in /symws/admin and is set to opac.  Vufind just reports 'An error has occurred'.  Please let me know how to troubleshoot and get a more helpful error message.  

 

Nick Crimi

Joyner Library, web services

East Carolina University