Have you turned on development mode in order to get a detailed backtrace of the exception causing the error page?  You can do this by editing httpd-vufind.conf; there’s a variable in there you can uncomment to activate development mode.  (Don’t forget to restart Apache after making the change).  It might also give you more information to turn on debug mode in config.ini and/or to look at your Apache error log.

 

Please let me know if you need further assistance after trying all this!

 

- Demian

 

From: Martin Fuchs [mailto:mfuchs@subkom.de]
Sent: Monday, July 29, 2013 4:50 PM
To: Vufind-tech@lists.sourceforge.net
Cc: akiener@subkom.de
Subject: [VuFind-Tech] error when placing a hold

 

We have still problems with the holds and our new ILS-Driver for VuFind 2.0.

 

We have problems when placing a hold. After I press the button "Place a Title Level Request" I am redirected to a new site containing "Hold", the specified variables from HMACKeys and the hashKey.
But this page shows the typical "an error occurred" page. I think the phtml-file belonging to the "Hold"-page is the file /themes/blueprint/templates/record/hold.phtml.
Therefore I tried to find the error in this file, even commented out everything in it, but still the error remains.

Could you give us some advice where I have to search for the error shown on the "hold" page? Or could you tell me if there is a log-file showing the call-stack of the websites, so I can find out myself which parameters in vufind refer to which phtml file?

 

 

Martin

subkom gmbh