I don't believe that you're missing any configuration options -- the settings you mentioned in config.ini should cover it.

 

Unfortunately, I don't have SIP2 set up here, so I can't test it myself, but I'm pretty sure that somebody reported getting it working a few months ago, so I think it's theoretically possible.  It's been so long that I can't remember who it was, though -- maybe they'll speak up and offer some additional advice.

 

In the meantime, a couple of thoughts:

 

1.) While web/sys/SIP2.php handles the low-level SIP2 stuff, you might also want to look at web/sys/authn/SIPAuthentication.php, which handles the higher-level parts of the VuFind authentication.  You could probably add some debug statements in there to figure out where the code is flowing and what data is coming back -- that might give you some clues to help with troubleshooting.

 

2.) If you're unable to connect to the SIP2 service using tests independent of VuFind, is it possible there's some sort of network issue at work here?  A firewall blocking a port, or an IP not in a whitelist?

 

Please let us know how things go!

 

- Demian

 

From: Michael Vandenburg [mailto:michael.vandenburg@queensu.ca]
Sent: Friday, January 29, 2010 1:28 PM
To: vufind-general@lists.sourceforge.net
Subject: [VuFind-General] SIP2 connections for Voyager

 

Hi all,

 

I’m testing VuFind for my institution and have an instance up and running with a small set of records loaded.  It’s pretty gratifying.

 

My next steps are to get the item status from my ILS and enable the patron login.

 

I thought that I would try to use SIP2 for user authentication, but I’m running into some difficulties with it.

 

In the conf.ini file I’ve set ‘method = SIP2’ and filled in the values for host and port in the SIP2 section.

 

I don’t see any other places that require configuration for SIP, but it’s possible I’ve missed something.

 

Now when I go to login, the page spins it’s wheels and never goes anywhere.

 

I’ve had a look at the vufind\web\sys\SIP2.php file, and it’s really just the sip2.class.php that John Wohlers wrote.  I tried to work directly with John Wohlers’ code and usage examples, and have not been able to get them to work with my ILS either.

 

The ILS is Voyager, and it requires a SIP login which the SIP2.php shows as an untested function.  Well, I’ve tested it and can’t get it to work.

 

Has anyone else using Voyager been able to get SIP2 user authentication working with VuFind?

 

If I can’t make any progress with this I’ll switch to using the ILS option for user authentication, but I have other projects involving SIP and would like to get it to work if possible.  Any help would be appreciated.

 

Thanks,

-Michael

 

_____________________________________________________________________

Michael Vandenburg | Systems Librarian | Queen's University Libraries

Kingston ON, K7L 5C4 | 613-533-6000 x 74536