I recommend looking at r4395 in the trunk to see the basic changes necessary to use Solr 3.x; it should be possible to apply these modifications to 1.2.  Most of the changes relate to the fact that date sorting had to be revised due to tighter restrictions on sorting multi-valued fields.  You will also need r4369 for a version of the SolrMarc importer that works with Solr 3.  Also, see r4398 for an important fix.

 

Of course, VuFind 1.3 comes out on Monday.  It might be simpler to upgrade than to patch things piecemeal.

 

Let me know if you have more questions!

 

- Demian

 

 

From: Viviane Ventura [mailto:vaventura1@yahoo.com.br]
Sent: Thursday, January 26, 2012 11:11 AM
To: vufind-general@lists.sourceforge.net
Subject: [VuFind-General] Solr 3.5

 

Hi, folks!

It's possible upgrade solr for its latest version at vufind 1.2, without problems?

Thanks!