Two things to try next:

 

1.       If you manually run /etc/init.d/vufind start, does it work from the console?  If so, does /tmp/vufind_jetty.txt get created in that case?  That will help determine whether there is a problem with the vufind wrapper script or a problem with the context in which it is run on startup.

2.       Assuming that /etc/init.d/vufind works in some circumstances, the next step is to add some more redirected echo lines like the one that updates /tmp/vufind_startup.txt inside the /usr/local/vufind/vufind.sh script itself – this should help you figure out a) if the script is getting called at all and b) where it is failing if it is getting called but not running the whole way through.

 

Let me know if you still need more help after you have tried these things.

 

- Demian

 

From: Adam Chandler [mailto:adam@vichummert.org]
Sent: Thursday, April 21, 2011 12:01 AM
To: Demian Katz
Cc: vufind-general@lists.sourceforge.net
Subject: Re: [VuFind-General] Running VuFind Automatically

 

Interesting.  The script was called with 'start'.  This was written to /tmp/vufind_startup.txt:  Called with start on Thu Apr 21 03:50:38 GMT 2011

 

 '/tmp/vufind_jetty.txt' on the other hand does not exist.

 

Adam

 

 

On Apr 20, 2011, at 8:54 AM, Demian Katz wrote:



You might be able to troubleshoot by adding a few more lines to the script:

 

#!/bin/sh

### BEGIN INIT INFO

# Default-Start: 2 3 4 5

# Default-Stop: 0 1 6

# Description: VuFind init script

### END INIT INFO

echo "Called with $* on `/bin/date`" >> /tmp/vufind_startup.txt

cd /usr/local/vufind

export JETTY_CONSOLE=/tmp/vufind_jetty.txt

./vufind.sh $*

 

The echo line should update a log file that will show you when, and with which parameter(s), your startup script was called.  The JETTY_CONSOLE variable allows Solr’s startup information to be logged to a file…

 

If you update /etc/init.d/vufind to the version above and reboot, you may get some clues by checking the existence and contents of /tmp/vufind*.txt.  If this doesn’t offer an obvious explanation, feel free to share your findings here for more suggestions.

 

- Demian

 

From: Adam Chandler [mailto:adam@vichummert.org] 
Sent: Tuesday, April 19, 2011 7:56 PM
To: Demian Katz
Cc: vufind-general@lists.sourceforge.net
Subject: Re: [VuFind-General] Running VuFind Automatically

 

Demian,

 

Good news:  Your script was accepted by the chkconfig add utility.

 

Bad news:  Vufind is still not starting on boot.

 

 

Adam

 

 

On Apr 18, 2011, at 9:34 AM, Demian Katz wrote:




It looks like the chkconfig script under Fedora expects some special lines in the VuFind startup process in order to work properly.  Rather than copying vufind.sh into /etc/init.d, it looks like the best solution is to create a wrapper script.  I have updated the documentation accordingly:

 

 

Please let me know if you still have any questions!

 

- Demian

 

From: Adam Chandler [mailto:adam@vichummert.org] 
Sent: Sunday, April 17, 2011 9:03 AM
To: vufind-general@lists.sourceforge.net
Subject: [VuFind-General] Running VuFind Automatically

 

I am having some difficulty getting vufind to start on boot.  This is mostly caused by my lack of linux admin experience. 

 

OS version:  Fedora release 12 (Constantine)

 

 

I am starting from the instructions on the vufind site (http://vufind.org/wiki/starting_and_stopping_vufind).  Based on those instructions here is what I have done so far.  I copied the vufind.sh script to /etc/init.d, renaming it 'vufind'.

 

Problem 1:

 

When I run the script  from the command line it starts vufind, but it can't find the index, so the vufind UI displays 0 records for every search.

 

Problem 2: 

 

Putting Problem 1 aside for the moment, when I try to add the script using chkconfig I get this error:

 

root@test2 init.d]# chkconfig --add vufind

service vufind does not support chkconfig

 

I am assuming some of you have dealt with this already.  

 

Thanks,

Adam