Anuradha - when using the script you must include the name of the marc export file to import.  For example:

./ export.marc

This will tell the script to read the export.marc file.


On Fri, Oct 31, 2008 at 12:35 AM, Anuradha KT <> wrote:

--- On Thu, 30/10/08, Anuradha KT <> wrote:
From: Anuradha KT <>
Subject: RE: [VuFind-General] How to import records
To: "Wynn, Stephen" <>
Date: Thursday, 30 October, 2008, 7:08 PM

Dear Wynn Stephen,

Thanks for your reply.

I tried both the options but in vain.

1> With the first option, I got the following error: (I have disabled proxy for local host and

<STYLE type="text/css"><!--BODY{background-color:#ffffff;font-family:verdana,sans-serif}PRE{font-family:sans-serif}--></STYLE>
<H2>The requested URL could not be retrieved</H2>
<HR noshade size="1px">
While trying to retrieve the URL:
<A HREF=""></A>
The following error was encountered:
Connection to Failed
The system returned:
<PRE><I>    (111) Connection refused</I></PRE>
The remote host or network may be down.  Please try the request again.

2> with the second option

root@ncsi-desktop:/usr/local/vufind# ./
Loading properties from
Making sure the marc file exists...
Found /usr/local/vufind/import/catalog.mrc
Indexing Complete.  Now optimizing index...
Finished in 0:00.00
Indexed 1 at a rate of about

But when I restarted VuFind and searched for the record in the browser it did not retrieve any document.

I have attached both and files for your reference.

Thanks, Anuradha

--- On Wed, 29/10/08, Wynn, Stephen <> wrote:
From: Wynn, Stephen <>
Subject: RE: [VuFind-General] How to import records
Date: Wednesday, 29 October, 2008, 6:48 PM

When we had this problem it was because the import script was not committing the records.


Try one of these:

At the command line enter:

curl --data-binary '<commit/>' -H 'Content-type:text/xml; charset=utf-8'


Alternatively, open the script and scroll down to very near the end.  Just above the section, "Commit data to SOLR", find the line:

exec $RUN_CMD

Change this to:



Stephen Wynn
Head of Technical Services and Systems
Pickler Memorial Library
Truman State University
Kirksville, MO 63501
(660) 785-4535

From: Anuradha KT []
Sent: Wednesday, October 29, 2008 2:11 AM
Subject: [VuFind-General] How to import records


Hello list,

I have installed VuFind version 0.8.2 on a Ubuntu OS. When I tried to import MARC records through it says indexing is done successfully but I am not able to search the imported records. Could you please let me know where I am going wrong?

Regards, Anuradha

Add more friends to your messenger and enjoy! Invite them now.

Add more friends to your messenger and enjoy! Invite them now.

Add more friends to your messenger and enjoy! Invite them now.
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
VuFind-General mailing list