You’re right, it does work fine.  I went through the process again and it worked.  We had added one column to the resource table and when the script tried to load data it stopped in the middle (when loading the resource table) and I didn’t catch the error message.  When I removed that column it worked just fine. 

 

Thanks,
Sean

 

From: Demian Katz [mailto:demian.katz@villanova.edu]
Sent: Tuesday, February 22, 2011 4:12 PM
To: Sean C Purcell; vufind-tech@lists.sourceforge.net
Subject: RE: db_RC1toRC2.php database upgrade script

 

There’s no version of that upgrade script other than the one that was in the release.  I haven’t heard about problems with it in the past.  Have you looked at the various intermediate files that the script generates?  Perhaps there’s a clue in there – if you want to share some data (off-list, obviously), I’m happy to take another look at it….

 

- Demian

 

From: Sean C Purcell [mailto:seanpurc@uga.edu]
Sent: Tuesday, February 22, 2011 3:33 PM
To: vufind-tech@lists.sourceforge.net
Subject: [VuFind-Tech] db_RC1toRC2.php database upgrade script

 

Hi All,

 

I’m finally getting around to importing tags/favorites/comments from our old VuFind RC1 mysql database to our VuFind 1.0 database.  Is there an updated version of the db_RC1toRC2.php database upgrade script?  It doesn’t appear to migrate data correctly.  Much of the data is copied to the new database, but several tables are empty: comments, user_resource, and resource_tags.   The version I’m using was downloaded with the RC2 release (vufind-1.0RC2.tar.gz).  I checked subversion to see if maybe it had been updated after the release, but this and the other RC1-to-RC2 upgrade files appear to have been removed from the /upgrade folder in the VuFind trunk.   I’m working now to get the database functional, but if anybody has a working version of the upgrade script, let me know J

 

Thanks,

Sean