Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Does vtcl work with tcl 8.5.2

Help
2008-06-30
2013-05-08
  • Don Rozenberg
    Don Rozenberg
    2008-06-30

    Hi,

    Just installed tcl/tk 8.5.2 and tried to run vtcl 1.6.1.a1 on Linux Kubuntu 7.04.

    Got the messages:

    wish8.5 vtcl.tcl
    Error in startup script: version conflict for package "Tk": have 8.5.2, need exactly 8.5
        while executing
    "package require -exact Tk $tcl_version"
        invoked from within
    "if {$tcl_version < 8.0} {
        return -code error "tkcon requires at least Tcl/Tk8"
    } else {
        package require -exact Tk $tcl_version
    }"
        (file "/home/rozen/pkg/vtcl-1.6.1a1/./lib/tkcon.tcl" line 40)
        invoked from within
    "source /home/rozen/pkg/vtcl-1.6.1a1/./lib/tkcon.tcl"
        ("uplevel" body line 1)
        invoked from within
    "uplevel #0 [list source $file]"
        (procedure "vTcl:load_lib" line 11)
        invoked from within
    "vTcl:load_lib $i"
        (procedure "vTcl:load_libs" line 4)
        invoked from within
    "vTcl:load_libs $LIBS"
        (procedure "vTcl:setup" line 51)
        invoked from within
    "vTcl:setup"
        (procedure "vTcl:main" line 39)
        invoked from within
    "vTcl:main $argc $argv"
        (file "vtcl.tcl" line 723)

    Are there plans to make vtcl work with tcl8.5.2?

    Thanks in advance,
    Don

     
    • Isaias Prestes
      Isaias Prestes
      2008-09-12

      Change
      package require -exact Tk $tcl_version
      to
      package require Tk $tcl_version

      Best regards