#179 Start-up error with Tcl 8.5.8

open
nobody
None
5
2010-01-20
2010-01-20
Anonymous
No

The file Tkcon.tcl has a "package require exact" line which returns an error saying that it needs exactly 8.5, but it has found 8.5.8 and then bombs out before displaying any windows.
Commenting this line out allows Visual Tcl to start. (I don't know how to correct yet, as am a newbie.)

Discussion

  • Zhang Weiwu
    Zhang Weiwu
    2010-03-28

    I can tell what happens if you comment out that. upon confirm newly project's name, error message follows:
    bad variable name "vTcl(w,opt,-background)": upvar won't create a scalar variable that looks like an array element

     
  • Zhang Weiwu
    Zhang Weiwu
    2010-03-28

    to add that I am using 1.6.1a

     
  • Zhang Weiwu
    Zhang Weiwu
    2010-03-28

    and also reproducible with 1.6.0

     
  • Thanks a lot, I have tk 8.5.2 and I tried both, commenting the line and removing "-exact", both worked fine and now the vtcl is running. I'm not sure what Im going to do with tcl but a new languaje is never a burden to learn.