Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#172 Version Conflict?

open
nobody
None
5
2008-05-15
2008-05-15
Penny Lawson
No

Looks like the same problem as César Augusto Vargas Deza, 1963533 Don't run Visual Tcl.

Error in startup script.

Version confict for package "Tk"; have 8.5.2, need exactly 8.5
while executing
"package require -exact Tk $tcl_version"
invoked from within
"if {$tcl_version < 8.0} {
return -code error "tkcon requires at least Tcl/Tk8"
} else {
package require -exact Tk $tcl_version
}"
(file "C:/ProgramFiles/vTcl/lib/tkcon.tcl}"

Rest of Error message same as Mr. Deza's.

Discussion

  • Logged In: NO

    change
    package require -exact Tk $tcl_version
    to read
    package require Tk

     
  • Logged In: NO

    Appreciate your dedication.
    Thanks.

     
  • Logged In: NO

    After changing the line
    package require -exact Tk $tcl_version
    to
    package require Tk
    in the $VTCL_HOME/lib/tkcon.tcl, the application did start without any conflict.

    But when opening sample files, it shows an error "Missing value to go with key"

     
  • Zurd
    Zurd
    2009-07-07

    Thank you for the trick, I'm on Linux and I changed at line 40 in "tcl-1.6.1a1/lib/tkcon.tcl" the string and it works now.