Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Linux build process

2010-10-20
2013-04-25
  • No autoconf files after getting latest code from SVN?  What is the best way to either get them or generate them?

     
  • Tried to jump start things by taking the configure.in from the tar file.  This just produces an error about AM_PATH_LIBGNUTLS not defined when running autoreconf.

     
  • I have gotten this far:

    checking for gsasl_check_version in -lgsasl… yes
    checking for libgnutls-config… no
    checking for libgnutls - version >= 2.0.0… no
    *** The libgnutls-config script installed by LIBGNUTLS could not be found
    *** If LIBGNUTLS was installed in PREFIX, make sure PREFIX/bin is in
    *** your path, or set the LIBGNUTLS_CONFIG environment variable to the
    *** full path to libgnutls-config.
    configure: error: can't find an usable version of GNU TLS library

    Why is there a dependency on libgnutls-config if it is deprecated?

     
  • So I did not realize the use of sconf for building applied to linux as well.  I am able to build the main trunk now.

     
  • M.S. Babaei
    M.S. Babaei
    2010-11-01

    Exactly the same problem on Gentoo. (On FreeBSD works fine.)

    // Gentoo

    checking for libgnutls-config… no
    checking for libgnutls - version >= 1.2.0… no
    *** The libgnutls-config script installed by LIBGNUTLS could not be found
    *** If LIBGNUTLS was installed in PREFIX, make sure PREFIX/bin is in
    *** your path, or set the LIBGNUTLS_CONFIG environment variable to the
    *** full path to libgnutls-config.

    As you can see it already there:
    *  net-libs/gnutls
          Latest version available: 2.10.2
          Latest version installed: 2.10.2
          Size of files: 7,283 kB
          Homepage:      http://www.gnutls.org/
          Description:   A TLS 1.2 and SSL 3.0 implementation for the GNU project
          License:       LGPL-2.1 GPL-3

    //FreeBSD

    checking gsasl.h usability… yes
    checking gsasl.h presence… yes
    checking for gsasl.h… yes
    checking for gsasl_check_version in -lgsasl… no
    configure: error: can't find an usable version of GNU SASL library

    // It's here too

    3rr0r# pkg_info | grep gsasl
    gsasl-1.4.0_1       GNU SASL Library

    Please help I need to build VMime.

     
  • M.S. Babaei
    M.S. Babaei
    2010-11-01

    Sorry I said "Exactly the same problem on Gentoo. (On FreeBSD works fine.)"
    But it is not building on both systems.