#7 VPython changes for GNOME 2 on Linux, 1/2

open
nobody
None
5
2006-04-12
2006-04-12
Hugh Fisher
No

This patch modifies Visual Python to detect and build
with the GNOME 2 libraries rather than GNOME 1.X.
Apologies in advance for the lengthy explanations if
you already understand how autoconf works.

The patch modifies configure.ac, Makefile.in, and
src/Makefile.in

I suggest 3.2.10 as the new version number. Whatever
you choose, cd into the top level visual directory and
patch -p1 < the-attached-patch-file

This doesn't change the configure script itself. To
complete the process:

cp /usr/share/aclocal/glib-2.0.m4 .
cp /usr/share/aclocal/gtk-2.0.m4 .
# Tested on Fedora Core 3, I can't think why anybody
# would change the location for aclocal but YMMV
aclocal
autoconf

Running the new configure script should now print out
something like "testing for GNOME 2 ..."

Discussion

  • Hugh Fisher
    Hugh Fisher
    2006-04-26

     
    Attachments
  • Hugh Fisher
    Hugh Fisher
    2006-04-26

    Logged In: YES
    user_id=604388

    26 April: ignore the stuff about copying glib-2.0.m4 and
    gtk-2.0.m4 from /usr/share/aclocal. It will work without it.