How to install on windows server

Amit Tyagi
2013-09-18
2013-09-19
  • Amit Tyagi
    Amit Tyagi
    2013-09-18

    I am trying to install it on windows

    Firstly i installed ruby then rails then uplode virtualx application folder on ruby sites folder and then
    open commend prompt like
    cd virtualx
    virtualx/rails server

    it shows error for install bundle
    then i tried this one
    install bundle on commend prompt
    it start to install all one
    but in the end it shows this one

    C:\Sites>cd virtualx

    C:\Sites\VirtualX>rails server
    Could not find linecache-0.46 in any of the sources
    Try running bundle install.

    C:\Sites\VirtualX>bundle install
    Fetching gem metadata from http://rubygems.org/.......
    Fetching gem metadata from http://rubygems.org/..
    Resolving dependencies...
    Using rake (0.8.7)
    Using Ascii85 (1.0.1)
    Using abstract (1.0.0)
    Using activesupport (3.0.3)
    Using builder (2.1.2)
    Using i18n (0.6.0)
    Using activemodel (3.0.3)
    Using erubis (2.6.6)
    Using rack (1.2.5)
    Using rack-mount (0.6.14)
    Using rack-test (0.5.7)
    Using tzinfo (0.3.33)
    Using actionpack (3.0.3)
    Using mime-types (1.18)
    Using polyglot (0.3.3)
    Using treetop (1.4.10)
    Using mail (2.2.19)
    Using actionmailer (3.0.3)
    Using arel (2.0.10)
    Using activerecord (3.0.3)
    Using activeresource (3.0.3)
    Using acts_as_tree (0.2.0)
    Using authlogic (2.1.6)
    Using bundler (1.3.4)
    Using cocaine (0.2.1)
    Using columnize (0.3.6)
    Using declarative_authorization (0.5.2)
    Using rbx-require-relative (0.0.9)
    Installing linecache (0.46)
    Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native exten
    .

        C:/RailsInstaller/Ruby1.9.3/bin/ruby.exe extconf.rb
    

    Can't handle 1.9.x yet
    extconf.rb failed
    Could not create Makefile due to some reason, probably lack of
    necessary libraries and/or headers. Check the mkmf.log file for more
    details. You may need configuration options.

    Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=C:/RailsInstaller/Ruby1.9.3/bin/ruby

    Gem files will remain installed in C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems
    .1/gems/linecache-0.46 for inspection.
    Results logged to C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/linec
    -0.46/ext/gem_make.out
    An error occurred while installing linecache (0.46), and Bundler cannot
    continue.
    Make sure that gem install linecache -v '0.46' succeeds before bundling.

    but it does not suppose to update it now tell me what to do please ...
    thanks

     
  • PIT Solutions
    PIT Solutions
    2013-09-19

    This looks like a gem dependency issue and it might be due to the version conflict with Ruby you have installed. We could see that you are using an updated version of ruby 1.9.3 which is not the supported ruby version for our product VirtualX. We request you to refer the deployment guide and as per which you need to install/use ruby 1.8.7 for successful installation of the product. You can check the ruby version by running the command 'ruby -v' in your console. After installing the correct version of ruby, redo the steps you have followed to set up the system. We hope that would work fine.

    Please revert to us if you come across any issue then.