eclipse 3.3.2

Help
yincrash
2008-07-14
2013-04-25
  • yincrash
    yincrash
    2008-07-14

    I'm using Eclipse 3.3.2, and I can't seem to use Violet as a plugin. I get "The selected wizard could not be started. ...  Reason: Plug-in com.horstmann.violet was unable to load class com.horstmann.violet.eclipseplugin.wizards.NewClassDiagramWizard."

     
    • bopaige
      bopaige
      2008-07-14

      Last I heard, the Violet plugin doesn't work in Eclipse due to changes in the Eclipse plugin API. It does work well as a standalone application, though, which is how I use it.

      The integration is not very strong when you do run it within Eclipse; the only interaction I've seen is the ability to drag-and-drop a class to the class diagram and it will create a Class picture for you with attribute names.

      HTH,

      Bobman