When starting Vicaya using Java 6 and alert dialog pops up that says something like "Java 1.4 or above required". Vicaya should run with Java 1.4, 1.5 (5), and 1.6 (6), and later versions.
Logged In: YES
There was code which literally looked for java.version = 1.4 | 1.5 . Java 6 is known as 1.6 and I support java7 will be 1.7. However, java6 also had some other problems (at least on Ubuntu 7.04) regarding the jdic tools (the tray, etc). jdic has been upgraded to 9.2 (I think) and checked in to svn.
Ubuntu 7.04, laptop, works with Sun's j2ee sdk1.4, java-1.5.0-sun and java-6-sun. No problems.
I tried it in Mac OS X 10.4.10 (JVM 1.5), Win 2000 (JVM 1.5 or 1.6). It works fine.
This is probably fixed.