Localhost not working

Support
neopagan75
2013-02-10
2013-05-08
  • neopagan75
    neopagan75
    2013-02-10

    I had Vertrigo 2.28 and all worked fine. I reinstalled Windows and I installed the latest 2.29 Vertrigo version, I changed nothing in my settings, just ran the Vertrigo, but the Localhost is not working. Can§t connect to localhost server… Can somebody help?

     
  • neopagan75
    neopagan75
    2013-02-10

    I found out, that this works: http://localhost:8080/  but the only http://localhost works not, but it worked with previous version…

     

  • Anonymous
    2013-02-17

    I have got same "problem" and question. Why is this default setting?

     

  • Anonymous
    2013-02-17

    And here's the answer:

    if you open up your httpd.conf file, look for the line around 46 for the following:

    #
    # Listen: Allows you to bind Apache to specific IP addresses and/or
    # ports, instead of the default. See also the <VirtualHost>
    # directive.
    #
    # Change this to Listen on specific IP addresses as shown below to
    # prevent Apache from glomming onto all bound IP addresses (0.0.0.0)
    #
    #Listen 12.34.56.78:80
    Listen 8080

    The directive, Listen 8080, defines what port Apache is to listen on. If you change it to Listen 80, then you'll be able to access your local websever as the book indicates: http://localhost.

    To expand a little further, the default port number for the http protocol is port 80, hence the reason you never have to type in the port number for a website. However, when you change the Listen directive to anything but port 80, then you have to specifically tell your browser which port to access the server on. In your case, it's port 8080. But the truth is, you can pick just about any number. Be careful, though, because there are many well known port numbers assigned to specific services. Check out the following link:

    http://www.iana.org/assignments/port-numbers

    Now the reason your server is on Port 8080 and not Port 80 is probably because of the type of installation you chose. During the install proccess, there is a section that asks you, For whom to install Apache. Most likely you selected, only for the Current User, on Port 8080, when started Manually . This option is available for security reasons or if you already have another webserver running on port 80.

    I hope this helps.