Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#633 Random crashes

v0.5.1
open
Crashes (68)
5
2014-02-01
2012-07-24
Anonymous
No

Vega Strike crashes constantly. It seems to happen randomly when I approach a planet, a base, or especially a jump point. Even cycling through HUD displays with the M key can cause it to crash when it displays the real-time camera of the target. I have already attempted lowering the graphics as far as they will go, and have tried playing without sound. I've also tried disabling "accelerated visual" and playing in various compatibility modes. None of this helps. although for some reason when I play with low graphics settings (which, I might add, is a harrowing experience given the complete blackness of the space around you) instead of just silently crashing I get a "Vega Strike has stopped working" message.

Windows 7 64-bit, 8 GB Ram, AMD HD 6850 (latest drivers), Intel Core i7 CPU 860

Discussion

  • Michael Walker
    Michael Walker
    2012-09-07

    Heya
    Just installed 0.5.1 r1
    I always crash silently when autopiloting to the second system scan objective, tried numerous things..setting processor affinity..no shader..no music..lowering texture & resolution specs..windowed..ati bug workaround..deleting openall32.dll & wrap_oal.dll.. to no avail.

    just tried an old 0.4.2 package and it jammed up on loading screen (have new machine since I played that)

    tried on both Windows XP & Vista 32 business (2 hard drives with diff os)
    Intel E6500 @ 2.93GHz 4GB RAM ATI Radeon HD 5450

    New graphics card has given me curry with things like Doom3 and Ageof EmpiresII - Had to lower the graphics hardware accellerator in XP to play them, (cannot play them in Vista). Tried various accelleration levels for VS but still same issue. perhaps there is some specific setting I need for catalyst drivers, eg GTAIV EFLC needs my mipmaps on maximum settings so it doesn't crash.

     
  • Pheonix Rising
    Pheonix Rising
    2012-11-30

    There are several possible problems that crop up and I think one of them has been fixed. Try the latest binary posted on svn. If it doesn't fix anything let us know. Also, post the error logs (stderror/stdout) so we can see if there is anything there to tell us about the crash or where it crashed if you try the new binary. If it wasn't a hidden sound issue it may be an opengl issue.

     

  • Anonymous
    2013-01-03

    Hello, I am also experiencing similar issues under Windows 7 with Vegastrike . it occurs with 0.5.1 r1 and with svn build 13473 with larest svn data. It usually occurs when aproaching stations planets or jump points, but also when exiting a station or jump point.

    Windows 7 64 bit, 8 gig ram, Intel Core i5 2400, ATI Radeon HD 5770, latest drivers.

    I've tried changing settings in VS Setup. setting Accelerated Visual Off doesn't work but setting shaders so simple or lower seems to reduce the frequency of the crashes.

     

  • Anonymous
    2013-01-03

    Hello, I am also experiencing similar issues under Windows 7 with Vegastrike . it occurs with 0.5.1 r1 and with svn build 13473 with larest svn data. It usually occurs when aproaching stations planets or jump points, but also when exiting a station or jump point.

    Windows 7 64 bit, 8 gig ram, Intel Core i5 2400, ATI Radeon HD 5770, latest drivers.

    I've tried changing settings in VS Setup. setting Accelerated Visual Off doesn't work but setting shaders so simple or lower seems to reduce the frequency of the crashes.

     

  • Anonymous
    2014-02-01

    Does anyone know the version where this didn't appear yet? I'm currently going through the versions backwards to find the one that's at least playable.

     
  • Klauss++
    Klauss++
    2014-02-01

    You should try SVN (check it out with TortoiseSVN). There was a bug with shaders and intel which we fixed in SVN that I think hasn't been included in the windows data pack.

     


Anonymous


Cancel   Add attachments