#6 Xlaunch doesn't work

closed-fixed
nobody
None
5
2014-08-19
2012-09-25
oper8
No

I can't get Xlaunch to work no matter what configuration I try.

The following xlaunch profile won't work for me:

<?xml version="1.0" encoding="UTF-8"?>
<XLaunch WindowMode="MultiWindow" ClientMode="StartProgram" LocalClient="False" Display="-1" LocalProgram="xcalc" RemoteProgram="xterm" RemotePassword="secret" RemoteHost="server.domain.local" RemoteUser="root" XDMCPHost="" XDMCPBroadcast="False" XDMCPIndirect="False" Clipboard="True" ClipboardPrimary="True" ExtraParams="" Wgl="True" DisableAC="False" XDMCPTerminate="False"/>

Always comes back with "Failure: Connection to server failed".

Starting VcXsrv then connecting to the server via PuTTY with X11 forwarding enabled works fine.

Discussion

  • oper8
    oper8
    2012-09-25

    Win XP SP3, no IPv6 installed.

    From XWin.log:

    _XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
    _XSERVTransOpen: transport open failed for inet6/MYWORKSTATION:0
    _XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6
    _XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
    _XSERVTransOpen: transport open failed for inet6/MYWORKSTATION:1
    _XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6
    _XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
    _XSERVTransOpen: transport open failed for inet6/MYWORKSTATION:2
    _XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6
    _XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
    _XSERVTransOpen: transport open failed for inet6/MYWORKSTATION:3
    _XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6
    _XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
    _XSERVTransOpen: transport open failed for inet6/MYWORKSTATION:4
    _XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6
    _XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
    _XSERVTransOpen: transport open failed for inet6/MYWORKSTATION:5
    _XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

    <snip>

    _XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
    _XSERVTransOpen: transport open failed for inet6/MYWORKSTATION:59531
    _XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6
    _XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
    _XSERVTransOpen: transport open failed for inet6/MYWORKSTATION:59532
    _XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6
    _XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
    _XSERVTransOpen: transport open failed for inet6/MYWORKSTATION:59533
    _XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6
    _XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
    _XSERVTransOpen: transport open failed for inet6/MYWORKSTATION:59534
    _XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

    Fatal server error:
    Failed to find a socket to listen on
    [ 16332.921] Server terminated with error (1). Closing log file.

     
  • oper8
    oper8
    2012-09-25

    Got it to work by specifying: -nolisten inet6

    VcXsrv should be made to detect the lack of an IPv6 interface.

     
  • marha
    marha
    2012-10-02

    • status: open --> closed-fixed
     
  • marha
    marha
    2012-10-02

    Problem has been fixed in commit 07be8c02a809f5bfacf5d195123a61f51708b9ca

    Will be incorporated in the next release after 1.12.99.0