This problem solved, it's a bug in our app. But i'll come with another question.


From: ningji@hotmail.com
CC: user-mode-linux-user@lists.sourceforge.net
Date: Tue, 20 Dec 2011 02:46:25 +0000
Subject: Re: [uml-user] stack smashing detected when running apps in the hostfs


just to be clear, if we run the application in the stand alone linux pc, never seen such errors.


From: ningji@hotmail.com
To: ningji@hotmail.com
CC: user-mode-linux-user@lists.sourceforge.net
Subject: stack smashing detected when running apps in the hostfs
Date: Tue, 20 Dec 2011 01:13:09 +0000

hi everyone,

i'm running 20 UMLs in linux,
each of them can access a public folder in the host linux.
( http://user-mode-linux.sourceforge.net/hostfs.html )
So i don't need to copy these apps/libs to each UML.

so i start all these UMLs at the same time, they will automatically run the same app
in the public fold (/mnt/host).

But i run into
stack smashing detected error
for 1 of our lib.so.

My questions is,
is these a bug in the application/lib itself,
or i'm running out of resources as i have 20 VMs ?

Thanks !
--



------------------------------------------------------------------------------ Write once. Port to many. Get the SDK and tools to simplify cross-platform app development. Create new or port existing apps to sell to consumers worldwide. Explore the Intel AppUpSM program developer opportunity. appdeveloper.intel.com/join http://p.sf.net/sfu/intel-appdev
_______________________________________________ User-mode-linux-user mailing list User-mode-linux-user@lists.sourceforge.net https://lists.sourceforge.net/lists/listinfo/user-mode-linux-user