hi all:
    I download kernel from: http://uml.devloop.org.uk/kernels/kernel64-2.6.35.14.bz2,
    download linux filesystem from: http://fs.devloop.org.uk/filesystems/Debian-Squeeze/Debian-Squeeze-AMD64-root_fs.bz2.
    After umcompress I do following steps:
    1) chmod +x   ./kernel64-2.6.35.14
    2)./kernel64-2.6.35.14 Debian-Squeeze-AMD64-root_fs umid=debian mem=256m eth0=tuntap,,,192.168.0.254
     In uml:
    1).use root login without password.
    2). ifconfig eth0 192.168.0.253 up   
[   18.370000] helper_wait : waitpid process 26858 failed, errno = 10
[   18.370000] * modprobe tun
[   18.370000] * ifconfig tap0 192.168.0.254 netmask 255.255.255.255 up
[   18.370000] * bash -c echo 1 > /proc/sys/net/ipv4/ip_forward
[   18.370000] helper_wait : waitpid process 26867 failed, errno = 10
[   18.370000] * route add -host 192.168.0.253 dev tap0
[   18.370000] * bash -c echo 1 > /proc/sys/net/ipv4/conf/tap0/proxy_arp
    3)ping -c 3 192.168.0.254
PING 192.168.0.254 (192.168.0.254) 56(84) bytes of data.
Warning: time of day goes back (-17544us), taking countermeasures.
64 bytes from 192.168.0.254: icmp_req=1 ttl=64 time=0.259 ms
64 bytes from 192.168.0.254: icmp_req=2 ttl=64 time=0.313 ms
64 bytes from 192.168.0.254: icmp_req=3 ttl=64 time=0.403 ms

   At uml step 2 have two failed: "helper_wait : waitpid process 26858 failed, errno = 10", but the network is reachable.
 When I run: ps axu|grep uml
uml-net   1352  0.0  0.0   3864   452 ?        S    08:51   0:00 /usr/bin/uml_switch -unix /var/run/uml-utilities/uml_switch.ctl
root     23417  0.0  0.0      0     0 pts/3    Z+   13:31   0:00 [uml_net] <defunct>
root     23422  0.0  0.0      0     0 pts/3    Z+   13:31   0:00 [uml_net] <defunct>
   have two zombie process here. When I run: 
   linux Debian-Squeeze-AMD64-root_fs umid=debian mem=256m eth0=tuntap,,,192.168.0.254
   have the same problem.Any idea ?
   I use debian 6.0 squeeze , uml-utilities version Version: 20070815-1.1

--
Best Regards,
Qin Bo